Echo Show 2nd Gen does not find any camera devices [SOLVED]



  • I cannot get Echo Show to recognize any of the camera devices on the Alexa App. Fire TV Cube finds them all.

    Echo Show 2nd Generation
    Amcrest IP4M-1054E Cameras
    Fire TV Cube
    Monocle Gateway

    I have several Amcrest cameras setup. All are setup in Monocle. I installed the Monocle Gateway running 24/7 on my network. The Fire TV Cube finds and displays all of the cameras. Echo Show Cannot find any devices by the camera names. If I say “Show Backyard” it responds, “Sorry. I didn’t find a device named backyard.”

    If I say “Show Backyard” on Fire TV Cube it is displayed.

    I have confirmed the Echo Show is listed on my Alexa App. All of the cameras are listed as devices on the Alexa App. I have tested the RTSP URL on VLC. All cameras are hardwired using IP addresses. The Echo Show is on the same network though via WiFi. The Fire TV Cube is on the same WiFi network as the Echo Show and in the same room.

    I have disabled and enabled the Monocle App several times on my Alexa App. I added two new cameras today and entered them in Monocle. Fire TV Cube found and displayed both cameras. Echo Show does not find them.

    Note: I installed the gateway after the failure to get Echo Show to recognize the devices. It did not help Echo Show. However, it does help Fire TV Cube.

    Echo Show is running Fire OS 5.5.3.7 (653622020) which is the latest software per the settings software update check.



  • Found the problem.

    My wife and I have shared Amazon Prime accounts. The Echo Show got linked to my wife’s account. I told Echo “link to ‘MYNAME’s’ account” and that solved the problem.



  • @ggillen

    Glad you were able to get it working!

    Thanks, Robert


Log in to reply