DS-7204HUHI-K1 / P Cant get it working but all settings and DNS seem correct??



  • Im just getting camera is not responding…

    This is on start up

    
    MONOCLE RUNTIME ENVIRONMENT
    -------------------------------------------------
    VERSION   = 0.0.4
    OS/ARCH   = win32\x64
    PROCESS   = monocle-gateway (PID=14236)
    TIMESTAMP = 2020-06-08T03:21:10.912Z
    
    -------------------------------------------------
    MONOCLE GATEWAY SERVICE         (Version: 0.0.4)
    -------------------------------------------------
    [Monocle Starting]
    [Monocle Connecting]
    [Monocle Started]
    [RTSP Server Starting]
    [RTSP Server Listening] 0.0.0.0:8555 (RTSP)
    [RTSP Server Listening] 0.0.0.0:443 (RTSP-TLS)
    [RTSP Proxy Started] (PID=15856)
    [RTSP Server Listening] 0.0.0.0:8554 (PROXY)
    [RTSP Server Started]
    [Monocle Connected]
    [RTSP Server Registered]
    
    -------------------------------------------------
    MONOCLE RTSP SERVICE - INITIALIZED
    -------------------------------------------------
    FQDN = bd93ddd2-0d85-49bd-9e35-96753575xxxx.mproxy.io
    HOST = 192.168.1.32
    PORT = 443
    ------------------------------------------------
    
    then when i request a camera  
    
    INITIALIZE RTSP STREAM:  Front Door Cam
    -------------------------------------------------
     - NAME  : Front Door Cam
     - LABEL : PRIMARY
     - URL   : rtsp://192.168.1.50:554/Streaming/channels/102
     - UUID  : STREAM:d283d6b7-9773-4713-9c5d-14f360exxxx
     - SESS  : 5516a64d-d7de-405b-b7e1-0a5cde4cxxxx
     - MODIF : Mon Jun 08 2020 04:09:44 GMT+0100 (GMT Summer Time)
     - TAGS  : @tunnel
    -------------------------------------------------
    
    
    -------------------------------------------------
    INITIALIZE RTSP STREAM:  Front Door Cam
    -------------------------------------------------
     - NAME  : Front Door Cam
     - LABEL : PRIMARY
     - URL   : rtsp://192.168.1.50:554/Streaming/channels/102
     - UUID  : STREAM:d283d6b7-9773-4713-9c5d-14f360e8xxxx
     - SESS  : 13b88992-b195-410f-a2ae-1c4d884exxxx
     - MODIF : Mon Jun 08 2020 04:09:44 GMT+0100 (GMT Summer Time)
     - TAGS  : @tunnel
    -------------------------------------------------
    

    Tried all Tag combinations

    DNS resolves to my computers IP

    tried BASIC and Digest Auth Main and Substreams

    any help appreciated…



  • @Paulcf007

    In your log, we are missing any TCP/RTSP connection attempts from the Alexa device after an “INITIALIZE” camera request. This is almost always a networking related issue. It could be a firewall blocking inbound connections on port 443 on the machine running the Monocle Gateway. Make sure your Alexa devices and Monocle Gateway are on the same network and not on a GUEST or isolated VLAN where they can’t communicate.

    The most likely issue is DNS REBINDING. This is where your router won’t allow the DNS entry bd93ddd2-0d85-49bd-9e35-96753575xxxx.mproxy.io resolve back to your gateway instance at 192.168.1.3. Some routers block this to prevent attacks, but in this case, the Alexa devices must connect to a DNS hostname and we want to resolve to the Monocle Gateway running inside your network so that all your camera streaming data is kept private and local to your network and not streamed over the Internet.

    Thanks, Robert


Log in to reply