Updated RasPi to latest NOOBS version and now updated Monocle Gateway to v.0.0.4 and now service will not run....[SOLVED]

  • as above, the application installs but when you check it says the Monocle Gateway service being skipped!!!

  • @pyranna has anyone come across this issue where the Gateway service seems to just skip running? Was wondering whether it has something to do with the permissions on the pi, but unfortuntely i have very little experience with Linux… Hoping someone can help. Just to say this was working perfectly before i updated my pi to the latest software plus the Monocle Gateway software. I was running v0.0.3. Wish i never touched it now…

    Many thanks,


  • @pyranna

    I’ll have to try the installer on the latest Raspbian. I’m sure it’s probably something simple that needs to be fixed in the installer.

    In the meantime, take a look at these instructions for a manual linux install via Shell script:

    If something fails, you should be able to issue the individual commands and see where it fails at least.

    Thanks, Robert

  • Hey. Just FYI my install was done with latest Buster build and 0.0.4 gateway. Did a headless SSH install and enabled Desktop after the fact. All works okay. Do make sure the token file is placed in the directory before you install.


  • right, i have sorted it! I tried doing the install manually, which appeared to show their was an issue with the token file. I revoked the token and did it again. It would seem that the first time i recreated the token file it saved it as a .txt file rather than a .token file! For some reason i wasnt allowed to move the token file to the etc/monocle folder however i moved it to the pi/monocle-gateway folder. I then run the command to initiate the monocle gateway, and hey presto it works!!!

  • I also just tested it today on latest RaspberryPi OS (buster) and all is working for me too.
    You should be able to rename your monocle token file, you may have to use the sudo command in front of your mv operation because /etc/monocle requires administrative access permissions.

    FYI, I also tested on the BETA RaspberryPi OS 64 bit with success using the ARM64 build available here:

  • Is it essential to have the token file in the directory etc/monocle…? Are there any consequences to the running of gateway with the token file in the other directory?

  • @pyranna

    No, it’s fine in the same directory as the executable. We suggest the /etc/monocle folder because that’s a more common Linux config path. However if future versions support a web interface allowing the user to change the token, then a fixed path may be required then.

    Thanks, Robert

Log in to reply