Facebook Portal devices with built-in Alexa



  • I have Monocle and the v0.0.4 Gateway running successfully with my Unifi UVC NVR and my Show 5’s. I wanted to add a 10" device in the kitchen to watch my cameras when required and video call with family in COVID times, and settled on the Facebook Portal. The camera on the Portal is much better for video calls and it has Alexa “built in”, which I hoped would mean it worked with Monocle.

    So far, no luck. My Ring doorbell works on both the Show 5 and the two Facebook Portals I just got (10" and TV). UVC thru Monocle (using @tunnel) works fine on the Show 5, but the Portals just show “Waiting for camera…” for a bit, then say “Camera doesn’t support that”.

    I’ve tried with Tunnel, Proxy and Proxy-TCP, and with NoAudio in case it’s the audio codec it’s not liking. I also tried without any tags in case the version of the Alexa client in the Portal was happy talking straight to the NVR. No luck. I’ve also tried all three resolutions that the UVC offers.

    Both the Portal and the Show are on the same network segment as the UVC and the Monocle Gateway, no firewalls in between.

    Full logs here.
    https://1drv.ms/u/s!AvFF8DnYNg4ziZYTtdECE2fIT6IdrA?e=a3vGZK
    The Portal log only gets as far as the INITIALIZE RTSP STREAM step. It has all the same details as when the Show 5 does it, but obviously different UUID and SESS.

    Where the Show 5 log moves on to RTSP CLIENT SOCKET CONNECTED and RTSP CLIENT ATTACHED TO STREAM, the Portal log just stops there. No error given, just no next step happens.

    Any thoughts on what to try next greatly appreciated.


Log in to reply