Not able to connect to Reolink cameras



  • I have multiple Reolink cameras and I have installed monocle gateway but still not able to connect to it. The gateway log show the stream getting initialized and then nothing

    I am able to connect to my Ubiquiti cameras without any issues.

    My setup:
    Cameras: Reolink: RLC-422,RLC423 and RLC-410, Ubiquiti: UVC-G3-Dome
    Display device Amazon Fire HD Tablet, Amazon Fire TV $K ultra



  • I have 3 Reolink cams (RLC 511, 410 and 423) and all show up on my Echo Show 8 without the need to run Monocle at all; I just use the Reolink Alexa smart app and the updated versions of camera firmware (which now support alexa).



  • I have RLN16-410 NVR which is on the latest firmware H3MB02, and i have enabled Reolink Smart Home and liked my reolink account, but it does not discover any of my cameras



  • My connection log on Monocle gateway
    my connection logs
    a3f7bacf-b996-4986-b3da-305ec1630f4b-image.png

    Front camera uses @tunnel, but it say camera is not responding
    87bf764e-e9e0-4e6b-8cb1-c8d595115bea-image.png

    Driveway camera uses @proxy, still same issue
    7f120367-2623-4c72-938a-fa2c46483ab0-image.png



  • I do not have an NVR; I use the Reolink PC software to view the 3 cameras (or my android phone with Reolink android app).
    To view on my Echo Show 8 or Show 5 I simply had to enable the Alexa smart home Reolink app and then I can ask Alexa to show me Camera 1 , Cam 2 or Cam 3. The requested camera view then appears on screen some 10 seconds later.
    You could try this (as a test) on individual cameras if you have a way of running them without the NVR (more or less duplicating my setup).



  • I tried connecting one of my camera directly to LAN, configured in the app, then enabled in the Smart Home of the reolink app. I was able to recognize the camera in the alexa app but when I say show the “camera name”, it say connecting to reolink and then says camera is not responding and quits



  • After I connected the Reolink camera directly to router instead of NVR It did work with Reolink and Alexa app’s Reolink smart Home Skills without using Monocle. But still not working with Monocle Gateway



  • See if you can get the NVR to work directly with Alexa.



  • I check with reolink support, they said the cameras are connect to NVR they wont work with alexa, so they said to connect all camera to a POE switch on the network and then use NVR to connect to the camera thru LAN for recording



  • @tcj2001 thank you; that is useful to know.



  • Finally got it working thru monocle gateway.

    I have the monocle gateway installed on a raspberry pi zero, it has nginx open source web server that was using port 443, so monocle gateway was not able use it. I uninstalled nginx from raspberry pi and that fixed the issue.

    I changed all rtsp url to use sub stream (rtsp://192.168.1.104:554/h264Preview_14_sub) with a lower resolution of 1920 x 1200 since I am using Fire HD 10 to display the stream)

    On monocle gateway I am using digest for authentication and just using @tunnel tag.

    The main stream of RTSP and higher resolution gives error.

    Some of my cameras are directly connected to LAN and some are connected to NVR both works fine now.

    Hope this will help others.



  • Even more useful for future Reolink users. Thanks for letting us know…

    Chris Muriel, UK.


Log in to reply