Not able to connect to Reolink cameras using monocle gateway



  • I have installed monocle gateway, but not able to connect to reolink cameras, i can connect to Ubiquiti camera with out issue

    my connection logs
    16b98c5c-8989-470c-8332-1082b17eb0e9-image.png

    Front camera uses @tunnel, but it say camera is not responding
    53cbfa5a-29b3-47d3-a275-c4c1f5fcd55a-image.png

    Driveway camera uses @proxy, still same issue
    6f18527f-2b56-4ff2-88c2-2195adbc3b4a-image.png

    My system
    Reolink: RLC-422, RLC 423, RLC 410, UVC-G3-Dome
    Amazon Fire HD, Amazon Fire TV 4k Ultra



  • Forgot to mention my Reolink cameras are connect to RLN16-410 NVR



  • I have exactly the same behaviour and issue using 3 RLC-410 connected to a RLN8-410.
    I also tested several tag combinations additional to the for Reolink recommended, but did not get the picture out. My log output is exactly the same as above.
    I see every request, but no picture output.
    Any ideas?



  • Forgot to mention I am using Echo Show 5 and Fire TV 4k for video output.



  • In the logs above, we can see the camera request is made to the Monocle Gateway instance, but nothing happens after the request. What we would expect to see are incoming TCP/RTSP connections from your Alexa device and outbound TCP/RTSP connection to the IP cameras getting logged. So this typically means the Alexa device is not able to talk to the Monocle Gateway instance.

    This is almost always due to some network issue. The most likely issue is DNS REBINDING

    Many routers, by default, will block requests to DNS hostnames that point to internal/private IP addresses. You have to either disable DNS REBINDING blocking or more preferably create an exception allowing only the Monocle proxy DNS hostnames thru.

    See: https://monoclecam.com/monocle-gateway/troubleshooting/dns-rebinding

    Other (less common) issues could be Alexa is on a different WiFi network such as a guest network or isolated VLAN.

    Thanks, Robert



  • Thanks a lot for this fast and very helpful answer, Robert!
    The DNS rebinding was exactly the problem. Now all Reolink camera streams are running!

    Thank you!!! 🙂


Log in to reply