ZiLink DH43H with rtsp proxy server or not?



  • Hi, Trying to connect my ZiLink DH43H Ip Camera with the Echo Show 8
    So far not successful.
    First I installed the cam in the monocle portal and cause it wasn´t working I installed the rtsp proxy server on my Raspi4.
    Currently using these settings:
    a9d80001-5bc4-4996-8240-7bec2b4d1f58-image.png

    still no success, Alexa says camera not answering.
    I am using the /11 for the 1920*1080 stream and I can display the original stream as well as the proxied stream on VLC.
    So this means generally it shoud work but it isn´t.
    Why do I need to install the gateway? I am using the monocle portal and this seems working, or am I wrong ?
    This is the portal I am using:
    5cdeb65d-5a49-4a5a-82fa-b9b01a05c3cd-image.png

    and this is the log I am getting with -V

    [11:27:19] openhabian@openhab:/rtsp-proxy-server$ sudo ./live555ProxyServer -V "rtsp://192.168.2.81:554/11"
    LIVE555 Proxy Server
            (LIVE555 Streaming Media library version 2018.02.28; licensed under the GNU LGPL)
    
    Created new TCP socket 4 for connection
    Connecting to 192.168.2.81, port 554 on socket 4...
    RTSP stream, proxying the stream "rtsp://192.168.2.81:554/11"
            Play this stream using the URL: rtsp://192.168.2.99/proxyStream
    
    (We use port 80 for optional RTSP-over-HTTP tunneling.)
    ...remote connection opened
    Sending request: DESCRIBE rtsp://192.168.2.81:554/11 RTSP/1.0
    CSeq: 2
    User-Agent: ProxyRTSPClient (LIVE555 Streaming Media v2018.02.28)
    Accept: application/sdp
    
    
    Received 715 new bytes of response data.
    Received a complete DESCRIBE response:
    RTSP/1.0 200 OK
    CSeq: 2
    Server: Hipcam RealServer/V1.0
    Content-Type: application/sdp
    Cache-Control: private
    x-Accept-Retransmit: our-retransmit
    x-Accept-Dynamic-Rate: 1
    Content-length: 473
    Content-Base: rtsp://192.168.2.81:554/11/
    
    v=0
    o=- 38990265062388 38990265062388 IN IP4 192.168.2.81
    s=10
    c=IN IP4 0.0.0.0
    t=0 0
    a=control:*
    a=range:npt=0-
    m=video 0 RTP/AVP 96
    a=control:trackID=0
    a=rtpmap:96 H264/90000
    a=range:npt=0-
    a=framerate:0S
    a=fmtp:96 packetization-mode=1;profile-level-id=000001;sprop-parameter-sets=AAAAAWdCACqWNUDwBE/LNwEBAQI=,AAAAAWjOMbI=
    a=framesize:96 1920-1080
    m=audio 0 RTP/AVP 8
    a=control:trackID=1
    a=rtpmap:8 PCMA/8000/1
    a=ptime:20
    a=fmtp:8 packetization-mode=1
    
    ProxyServerMediaSession[rtsp://192.168.2.81:554/11/] added new "ProxyServerMediaSubsession" for RTP/video/H264 track
    ProxyServerMediaSession[rtsp://192.168.2.81:554/11/] added new "ProxyServerMediaSubsession" for RTP/audio/PCMA track
    Sending request: OPTIONS rtsp://192.168.2.81:554/11/ RTSP/1.0
    CSeq: 3
    User-Agent: ProxyRTSPClient (LIVE555 Streaming Media v2018.02.28)
    
    
    Received 134 new bytes of response data.
    Received a complete OPTIONS response:
    RTSP/1.0 200 OK
    CSeq: 3
    Server: Hipcam RealServer/V1.0
    Public: OPTIONS,DESCRIBE,SETUP,TEARDOWN,PLAY,SET_PARAMETER,GET_PARAMETER
    
    
    Sending request: OPTIONS rtsp://192.168.2.81:554/11/ RTSP/1.0
    CSeq: 4
    User-Agent: ProxyRTSPClient (LIVE555 Streaming Media v2018.02.28)
    
    
    Received 134 new bytes of response data.
    Received a complete OPTIONS response:
    RTSP/1.0 200 OK
    CSeq: 4
    Server: Hipcam RealServer/V1.0
    Public: OPTIONS,DESCRIBE,SETUP,TEARDOWN,PLAY,SET_PARAMETER,GET_PARAMETER
    
    

Log in to reply