Esp32 micro rtsp on echo show 5



  • Hi, I’m trying to do a DIY doorbell camera with esp32 and ov2640. I’m using a library by geeksville for micro rtsp and have setup the monocle online with the camera. I understand I will need to install the gateway on one of my pc (it acts as a server and is on ethernet connection to router). The question is will installing the gateway allow the echo show to display the stream using Alexa? At the moment it just says camera not responding.

    Is there any guidance please. Thanks in advance.



  • Posts in summer 2020 suggest that ESP32 doesn’t work. BUT the only way to be sure is to install the gateway and play with the tags–@tunnel, @proxy, and @noaudio in particular. All but one of my cameras works with the gateway (Yi, Amcrest, Wyzecam). A Foscam RC2 looks like it should work as to RTSP and ONVIF, but won’t work through the gateway. It does, however, work directly with Alexa as a smart home device, so not a functional problem.



  • Thanks. I had a go at gateway I can see the connection request but something isn’t quite right. In the end Alexa says the camera isn’t responding and the connection closes. I am still new to all this so don’t know what the diagnostic is telling me. Mind taking a look at the attached shot of the cmd window i’m testing the gateway from please?
    image_2020-11-27_125901.png



  • Sorry, what I meant was does the information in the screenshot show anything that is not expected or a clue to whats wrong?
    thanks



  • I don’t think you can use @proxy-tcp and @tunnel together. I’d try @tunnel, @proxy, then @proxy-tcp, each without, then with, @noaudio.



  • @mudgen I see your string is looking for Mjpeg as the video type - I read somewhere this isn’t supported on Alexa - Can you change it to a mpeg or avi stream? Also, when I was trying to solve a problem I was having with a new doorbell, I got different results depending on the Show 5, Show 8 and show 10. The resolution of the device was a factor when I used the gateway. a 4k camera would not go for me no matter what I tried, but when I used the sub-stream it worked. Ultimately I was able to stop using the gateway altogether and use my Security server (blueIris) tied to Monocle and Alexa. Now I can have motion triggers in the camera cause the Alexa Show to display! works tits!
    Shu



  • @jshimota : it’s a @vipt26 post

    According to Robert, in June, Alexa will support mjpeg over rtsp (only), but he notes that he doesn’t have ability to test it.

    Remarks about different results with different Show devices are supported by other posts in these forums…

    Alexa will not support a resolution above 1080P, which apparently is why 4K won’t work.



  • Thats for the response - no doubt my reading was older info re: the mjpeg. Personally I don’t use it on any of my equipment so I have no personal experience. I had offered that as a way to flip switches to see if I could trigger help.
    I was reading on a rPI site about Alexa and the security changes imposed on the 8. Something about requiring TLS but again, I’ve no proof of that. I run an internal server with Certs installed, so my Gateway worked really well for all my Alexa displays. the 4k thing - glad to see someone confirm that! I’ve only got one 12MP camera but because it uses h265 I couldn’t implement it directly - and it was buffering and slow anyways! Once I twiddled the stream to use the 2ndary (I just use 4CIF (704*480) i’ve been problem free. thanks for the feedback on my post.



  • Hey thanks for your help, I have tried different tags and hopefully this log shows what the responses were. I think the very first attempt there was a brownout so the ESP32 rebooted, so ignore that first attempt.
    I can see different messages appearing in the attempts with different tags but I do not yet understand them as I am still new to IoT. If anyone is able to see what they mean and what tags appear to be giving the better response or if there are any further clues what the issue ,may be.
    Thanks[0_1606767326172_monocle.txt](Uploading 100%)



  • Ok so seems I cant upload txt files so how can I share the log?



  • @vipt26
    That’s weird that they will only accept image files. I’d either cut and paste the text from a terminal console or take a screenshot and upload that.



  • This is @proxy, @ tunnel. It seems that the connection is attempted around 3 times before giving up. I can’t copy and paste the text as it gets seen as spam. So I am adding screenshot, it repeats this 3 times (hence why i think it attempts connection 3 times)

    image_2020-12-01_210033.png



  • This one is @proxy, @tunnel, @noaudio. I think its same as without noaudio

    image_2020-12-01_210627.png



  • This is @procy-tcp. with the tags as above I can see on serial monitor from arduino IDE an rtsp session is created, received DESCRIBE then the sessions close. But with this one after received DESCRIBE there is received OPTIONS, the received options repeats around 4 or 5 times. But Echo show did not display anything.

    This is the monocle screenshot.
    image_2020-12-01_211833.png



  • OK and finally @proxy-tcp, @noaudio , seems same as without noaudio. Seems that the Echo show is sending the OPTIONS request and I think the ESP RTSP protocol i’m using isn’t responding? I’m using this code for the ESP32, hevn’t looked through the code in depth so don’t know how it is supposed to handle the request.
    https://github.com/bnbe-club/rtsp-video-streamer-diy-14
    link text
    image_2020-12-01_213802.png


Log in to reply