Hikvision DS-2CD2212-I5 and Alexa echoshow 5 not working



  • Hi, my Hikvision DS-2CD2212-I5 and Alexa echoshow 5 not work.

    i set rtsp://192.168.0.205:556/Streaming/Channels/101 auth basic (i tried also digest) res 1280*720 H264 .
    User and pass are ok because on vlc work fine.
    i installed monocle gateway, started it and semms all ok, but when i open on aleza says wecam not answer,
    i tried all tags

    @tunnel
    @proxy
    @tunnel, @noaudio
    @proxy, @noaudio
    @tunnel, @noaudio, @fake-fmtp
    @proxy, @noaudio, @fake-fmtp
    

    anyone can help me?
    Thank youi



  • @flaviodg If you aren’t aware - what were the results of following the troubleshoot page?:
    https://monoclecam.com/troubleshoot
    What about the Alexa troubleshoot? :
    https://monoclecam.com/troubleshoot/tips ?

    VLC does local stream - so bypasses user/pass in some cases making the results only a partial verification. The Hikvision model you mention is a great camera with Onvif support - have you verified using ODM? (Onvif Device Manager)?
    Just some ideas - you may have already done all this but saying it doesn’t work but not showing the history makes it hard to know what you’ve done so far. Also, instead of the standalone gateway (which requires deeper knowledge of network/firewalls/ssl etc) , what are your results from using the webbased gateway? I’ve gotten multiple Onvif cameras to work using it - but struggled with the standalone gateway on my domain server… food for thought.
    Shu



  • @jshimota Thank you very much for answer.

    • i view on VLC that ask to me user and password
      ***** installed proxy on Home PC****
    monocle-gateway.exe
    
     ******************************************************************
     *             __  __  ___  _  _  ___   ___ _    ___              *
     *            |  \/  |/ _ \| \| |/ _ \ / __| |  | __|             *
     *            | |\/| | (_) | .` | (_) | (__| |__| _|              *
     *            |_|  |_|\___/|_|\_|\___/ \___|____|___|             *
     *                                                                *
     ******************************************************************
    
    
    -------------------------------------------------
    MONOCLE RUNTIME ENVIRONMENT
    -------------------------------------------------
    VERSION   = 0.0.4
    OS/ARCH   = win32\x64
    PROCESS   = monocle-gateway (PID=2180)
    TIMESTAMP = 2020-12-03T07:36:17.528Z
    
    -------------------------------------------------
    MONOCLE GATEWAY SERVICE         (Version: 0.0.4)
    -------------------------------------------------
    [Monocle Starting]
    [Monocle Connecting]
    [Monocle Started]
    [RTSP Server Starting]
    [RTSP Server Listening] 0.0.0.0:8555 (RTSP)
    [RTSP Server Listening] 0.0.0.0:443 (RTSP-TLS)
    [RTSP Proxy Started] (PID=19844)
    [RTSP Server Listening] 0.0.0.0:8554 (PROXY)
    [RTSP Server Started]
    [Monocle Connected]
    [RTSP Server Registered]
    
    -------------------------------------------------
    MONOCLE RTSP SERVICE - INITIALIZED
    -------------------------------------------------
    FQDN = 530296ea-9ff3-4663-8843-fa1cdb447e69.mproxy.io
    HOST = 192.168.0.69
    PORT = 443
    -------------------------------------------------
    
    **When i try to open camera without tags never happens**
    * **configured and installed API Token**
    
    * i used tags in all combinations, for examples
    
    -------------------------------------------------
    INITIALIZE RTSP STREAM:  Citofono
    -------------------------------------------------
     - NAME  : Citofono
     - LABEL : PRIMARY
     - URL   : rtsp://192.168.0.205:556/Streaming/Channels/102
     - UUID  : STREAM:90039705-e5be-423d-90f9-fdf646bd95fa
     - SESS  : c62ded48-1581-46d2-8f82-a2f480f0dc9d
     - MODIF : Thu Dec 03 2020 08:41:53 GMT+0100 (ora solare Europa occidentale)
     - TAGS  : @noaudio,@tunnel
    -------------------------------------------------
    

    and Alexa always says: mmmh–the webcam not responding

    How could i use webdased gateway?

    thank again



  • @flaviodg I’ve got a busy day today so can’t dig deep on this - but the part of your question ‘how to use web-based’ .

    (remove your locally installed proxy IMHO).
    https://portal.monoclecam.com/login

    Login and enter your camera info here instead of running the local gateway from Monocle. I am not saying bad things about the local gateway - just saying to try working it from another direction to see if you can break through! I’m out for the day.



  • Hi Flaviodg -
    I don’t see the cam connect to the gateway in the bit of text you sent - regardless… I notice your RTSP string is a bit abnormal to me - you use port 556 instead of 554. That can be okay, but it struck me as odd. You said that the specific string connects when used in VLC - is that true and verified?

    What were the results of using the web based Monocle? any luck? did any of the information on the Monocle readme/support/help stuff move you forward at all?
    Shu



  • @jshimota

     ******************************************************************
     *             __  __  ___  _  _  ___   ___ _    ___              *
     *            |  \/  |/ _ \| \| |/ _ \ / __| |  | __|             *
     *            | |\/| | (_) | .` | (_) | (__| |__| _|              *
     *            |_|  |_|\___/|_|\_|\___/ \___|____|___|             *
     *                                                                *
     ******************************************************************
    
    
    -------------------------------------------------
    MONOCLE RUNTIME ENVIRONMENT
    -------------------------------------------------
    VERSION   = 0.0.4
    OS/ARCH   = win32\x64
    PROCESS   = monocle-gateway (PID=9292)
    TIMESTAMP = 2020-12-09T10:54:44.656Z
    
    -------------------------------------------------
    MONOCLE GATEWAY SERVICE         (Version: 0.0.4)
    -------------------------------------------------
    [Monocle Starting]
    [Monocle Connecting]
    [Monocle Started]
    [RTSP Server Starting]
    [RTSP Server Listening] 0.0.0.0:8555 (RTSP)
    [RTSP Server Listening] 0.0.0.0:443 (RTSP-TLS)
    [RTSP Proxy Started] (PID=9460)
    [RTSP Server Listening] 0.0.0.0:8554 (PROXY)
    [RTSP Server Started]
    [Monocle Connected]
    [RTSP Server Registered]
    
    -------------------------------------------------
    MONOCLE RTSP SERVICE - INITIALIZED
    -------------------------------------------------
    FQDN = 530296ea-9ff3-4663-8843-fa1cdb447e69.mproxy.io
    HOST = 192.168.0.69
    PORT = 443
    -------------------------------------------------
    
    -------------------------------------------------
    INITIALIZE RTSP STREAM:  Citofono
    -------------------------------------------------
     - NAME  : Citofono
     - LABEL : PRIMARY
     - URL   : rtsp://192.168.0.205:556/Streaming/Channels/102
     - UUID  : STREAM:90039705-e5be-423d-90f9-fdf646bd95fa
     - SESS  : cd4439af-1e4a-4803-8eb5-891a9879ab9e
     - MODIF : Wed Dec 09 2020 11:53:47 GMT+0100 (ora solare Europa occidentale)
     - TAGS  : @proxy
    -------------------------------------------------
    
    2020-12-09T10:54:51.351Z [INFO]  [RTSP PROXY] REGISTERING STREAM [Citofono/PRIMARY]; (STREAM:90039705-e5be-423d-90f9-fdf646bd95fa)
    2020-12-09T10:54:51.356Z [DEBUG] <RTSP-PROXY> [REQUEST]  --> [REGISTER] rtsp://192.168.0.205:556/Streaming/Channels/102
    2020-12-09T10:54:51.356Z [TRACE] <RTSP-PROXY> [REQUEST]  --> [HEADERS] {
      "cseq": "1",
      "transport": "reuse_connection=0;preferred_delivery_protocol=udp;proxy_url_suffix=STREAM:90039705-e5be-423d-90f9-fdf646bd95fa;username=flavio;password=Martin@05"
    }
    2020-12-09T10:54:51.357Z [DEBUG] <RTSP-PROXY> [RESPONSE] <-- [200 (OK)] <cseq=1> (session=undefined)
    2020-12-09T10:54:51.357Z [TRACE] <RTSP-PROXY> [RESPONSE] <-- [HEADERS] {
      "cseq": "1",
      "date": "Wed, Dec 09 2020 10:54:51 GMT"
    }
    
    -------------------------------------------------
    INITIALIZE RTSP STREAM:  Citofono
    -------------------------------------------------
     - NAME  : Citofono
     - LABEL : PRIMARY
     - URL   : rtsp://192.168.0.205:556/Streaming/Channels/102
     - UUID  : STREAM:90039705-e5be-423d-90f9-fdf646bd95fa
     - SESS  : 6e719245-3efd-401c-9306-1937cdee96a1
     - MODIF : Wed Dec 09 2020 11:53:47 GMT+0100 (ora solare Europa occidentale)
     - TAGS  : @proxy
    -------------------------------------------------
    
    
    -------------------------------------------------
    INITIALIZE RTSP STREAM:  Citofono
    -------------------------------------------------
     - NAME  : Citofono
     - LABEL : PRIMARY
     - URL   : rtsp://192.168.0.205:556/Streaming/Channels/102
     - UUID  : STREAM:90039705-e5be-423d-90f9-fdf646bd95fa
     - SESS  : d61938f3-ee4a-42e0-aecd-06743592153f
     - MODIF : Wed Dec 09 2020 11:53:47 GMT+0100 (ora solare Europa occidentale)
     - TAGS  : @proxy
    -------------------------------------------------
    
    2020-12-09T10:55:44.656Z [INFO]  [RTSP PROXY] STREAM [Citofono/PRIMARY] WILL BE DE-REGISTERED IN 4 MINUTES
    [RTSP Server Stopping]
    [RTSP Server Stopped]
    [Monocle Stopping]
    [Monocle Stopped]
    [RTSP Proxy Stopped] CODE=3221225786; SIGNAL=null
    

    thank you



  • @jshimota
    The same with tag @tunnel



  • @jshimota
    I tried also setting rtsp port on 554



  • Hiya - well I’m going to step away on this one - I have asked for a few specifics and not seen your answers to those questions - logs are interesting but don’t tell me the whole story. I hope someone else helps you better than I did!



  • @jshimota said in Hikvision DS-2CD2212-I5 and Alexa echoshow 5 not working:

    Hiya - well I’m going to step away on this one - I have asked for a few specifics and not seen your answers to those questions - logs are interesting but don’t tell me the whole story. I hope someone else helps you better than I did!

    Ciao, I think I’ve answered to ALL your questions, but that’s okay. I hope someone else can help me.
    regardless


Log in to reply