'Sorry, xxCamera is not responding'



  • I have 2 current model cameras with passwords (a Genbolt GB-100S and IEGeek Outdoor 1080p CT0414BKUK), functioning successfully via the CamHi app on devices and P2P Client program on PCs. One is wireless, the other hard wired, both on my single home LAN, which they share with the Amazon Show and Spot. Connectivity is not an issue - email alerts work, as does FTP recording and Alexa found them OK through the Monocle skill and lists them in Devices. VLC player successfully picks up the streams too, using the same parameters held in Monocle.

    Unfortunately, despite trying every possible combination of settings and tags in the Monocle account (@tunnel, @proxy, @proxy-tcp and @noaudio), Alexa stubbornly tells me, ‘Sorry, xxCam is not responding’, on both the Spot and Show8. The Monocle connection is ‘192.168.1.xx:554/’ and uses basic authentication, H264 and AAC.

    My thoughts are either that I’ve missed something in my Monocle setting, or possibly there is some security or port/gateway permissions setting somewhere which is interrupting specifically and only the final communication between Echo and cameras, since that is the single thing not working. Everything runs on a domain network with fixed IPs and all our Amazon devices have no problem doing anything else, so it is just Echo accessing the listed cameras which fails.

    With the mobile device app and PC client working, I’m not reliant on the Amazon devices but just wanted to see if I could view the cameras that way, out of curiosity.

    Any suggestions in idiot-proof language, please? Is there any way to access a log from the Echo, to see where it is failing? The Monocle history does not provide any clue.



  • @MartynWitt Forgot to add that I have tried it running gateway with a FireTV Stick too but the output from the gateway screen went straight over my head rather than help! 🙂



  • @MartynWitt said in 'Sorry, xxCamera is not responding':

    @MartynWitt Forgot to add that I have tried it running gateway with a FireTV Stick too but the output from the gateway screen went straight over my head rather than help! 🙂

    Using VLC player on the same Fire TV Stick (with the address 'rtsp://admin:[password]@192.168.1.48:554/2,800x600,H264,G711,authenticate=basic’does work BTW so it is looking very much like it’s a camera vs Monocle vs Alexa syntax issue?



  • @MartynWitt
    2,800x600 is supposed to be resolution? Lots of posts here indicate that Alexa won’t support outside 1920x1080. When that’s what’s wrong, “monocle-gateway --tail” generally will show everything going fine and connecting, then Alexa summarily closing the connection with no message.



  • 2 is the streaming channel, 800x600 is the resolution



  • @MartynWitt said in 'Sorry, xxCamera is not responding':

    2 is the streaming channel, 800x600 is the resolution

    Oh, duh. Sorry for the noise.



  • I now have a log output from Powershell, with gateway running. Alexa does not say the camera is not responding but is ‘not quite sure what went wrong’. Nor am I - this doesn’t mean anything to me!

    2021-01-14T15:34:45.464Z [INFO] [192.168.1.44:51118 <By6941ARv>] RTSP ENDPOINT AUTHENTICATION SUCCESSFUL: BASIC
    2021-01-14T15:34:45.464Z [INFO] [192.168.1.44:51118 <By6941ARv>] RTSP ENDPOINT SDP REMOVED AUDIO CHANNEL: [PORT=0; PROTOCOL=RTP/AVP; PAYLOADS=8]
    2021-01-14T15:34:45.466Z [DEBUG] [192.168.1.44:51118 <By6941ARv>] [CLIENT RESPONSE] <-- [200 (OK)] <cseq=1> (session=undefined)
    2021-01-14T15:34:45.466Z [TRACE] [192.168.1.44:51118 <By6941ARv>] [CLIENT RESPONSE] <-- [HEADERS] {
    “cseq”: “1”,
    “server”: “Hipcam RealServer/V1.0”,
    “content-type”: “application/sdp”,
    “cache-control”: “private”,
    “x-accept-retransmit”: “our-retransmit”,
    “x-accept-dynamic-rate”: “1”,
    “content-length”: “422”,
    “content-base”: “rtsp://192.168.1.48:554/2,800x600,H264,G711,authenticate=basic/”
    }
    2021-01-14T15:34:45.466Z [TRACE] [192.168.1.44:51118 <By6941ARv>] [CLIENT RESPONSE] <-- [BODY]
    v=0
    o=- 38990265062388 38990265062388 IN IP4 192.168.1.48
    s=11
    c=IN IP4 0.0.0.0
    t=0 0
    a=control:*
    a=range:npt=0-
    m=video 0 RTP/AVP 96
    a=rtpmap:96 H264/90000
    a=fmtp:96 packetization-mode=1;profile-level-id=000001;sprop-parameter-sets=AAAAAWdkABasO1BQFtCAAAADAQAAAwAZQg==,AAAAAWjuPOEAQkIAhIQETFIbk8V8n5P5PyfJ5uTJJCwiQpCcnk+vyf1+T68nJqTA
    a=control:trackID=0
    a=range:npt=0-
    a=framerate:0S
    a=framesize:96 640-352

    2021-01-14T15:34:45.648Z [INFO] [192.168.1.44:51118 <By6941ARv>] RTSP CLIENT SOCKET CLOSED
    2021-01-14T15:34:45.649Z [INFO] [192.168.1.44:51118 <By6941ARv>] RTSP CLIENT DETACHED FROM STREAM: DriveCam (STREAM:5fd2501b-f1d8-45c7-9bc4-4474bddb939d)
    2021-01-14T15:34:45.649Z [INFO] [192.168.1.44:51118 <By6941ARv>] RTSP ENDPOINT SOCKET CLOSED [192.168.1.44:51118 <By6941ARv>]

    Anyone able to translate this into Engliash please?



  • Anyone able to translate this into Engliash please?

    Or even English!!

    I am running everything on a Domain network - maybe I need to define a connection security rule?



  • @MartynWitt said in 'Sorry, xxCamera is not responding':

    Anyone able to translate this into Engliash please?

    Or even English!!

    I am running everything on a Domain network - maybe I need to define a connection security rule?

    Looks like your connection is working ok through the tcp/ip layer. Tried @fixaudio yet? fake-fmtp? Have a make and model for the cam? No expert here, just trying to get some info in the thread to draw and inform some views.



  • @mudgen Two cameras - Genbolt GB-100S and IEGeek Outdoor 1080p CT0414BKUK, both have the same problem, Yes it looks as if some connection is being made successfully but then nothing happens and the connection closes immediately. I have used the noaudio tag to rule out one possible issue. All is fine under other mobile and PC apps and VLC Player and so it has to be that Alexa is being sniffy about some setting or other. Perhaps she simply doesn’t like these cheap cameras.


Log in to reply