Camera not working on Show 8...gateway not configured right?



  • I am setting up my security system at my home, and I thought it might be neat to integrate my Amcrest IP cameras with my new Echo Show 8. So far, nothing works. Any insight would be much appreciated.

    1. Tried using the Monocle skill plain (no gateway) and that didn’t work.
    2. Installed the gateway and set it up per the instructions here and it still didn’t work.
    3. Resorted to searching google, and haven’t found a solution yet.

    This is how I have my system set up…

    Gateway files extracted to my C drive:
    5e65d8f9-a44d-4ef8-a57c-0676e2afb636-image.png

    First camera added like this (with @tunnel tag):
    5b623570-991b-4c33-a6dc-d226136d5f29-image.png

    Gateway as seen in elevated cmd (HOST = 10.19.1.138 is unexpected, I don’t know what that is):
    e2a2473a-5f5e-46d2-9bdc-bdc42bb6e8a5-image.png

    Gateway as seen when asking Alexa to “Show me the front door”:
    e160d0ad-6b95-42f5-81e2-f39437b5fdc6-image.png

    All Alexa does at this point is show me a screen that says “Waiting for Front Door” for about 20 seconds, then goes back to my homescreen without saying anything else.

    Just for fun, I tried the @proxy tag with the following results:
    e0a3840c-c7c9-49d7-b8b8-ff2e9823b505-image.png

    Still nothing on the Alexa except the “Waiting for Front Door”





  • @Ver1tas I had the same issue with the unexpected host ip address. It turns out it was a virtual adapter created by my vpn software. The easiest fix was to download and modify the Monocle.Properties file and put it in the Monocle directory. Just had to add my ip address and all was good.

    #--------------------------------------

    RTSP SERVICE REGISTRATION OVERRIDES

    #--------------------------------------
    #rtsp.register.fqdn=
    rtsp.register.host=192.168.1.13 <----- remove the hashtag and enter your ip address, restart service.
    #rtsp.register.port=443


Log in to reply