GATEWAY INSTANCE PROMOTED



  • Just started setting up and had most cameras working on Monocle for Windows 10. Then it all quit and I mucked around for a while with no success. All of a sudden BAM it was back. I checked the logs (I’m running gateway as a service) and saw where the log said GATEWAY INSTANCE PROMOTED and my computer IP number right when it started working.

    I rebooted my computer and seems that I can’t access cameras again. Is there a way to see where it is pointing for the gateway or force Promoting the Gateway back to my IP? Or is something else going on…



  • I got it resolved. Was doing some weird DNS Rebinding that I tracked down to PIAVPN (Private Internet Access VPN) I was running. It had created an adaptor with a local IP address using the Wireguard feature. I switched Wireguard setting to OpenVPN and it removed the virtual adapter and everything went back to normal. Hope this helps someone.



  • One more note, I ended up downloading and modifying the Monocle.Properties configuration file and putting in my gateway ip address. This way I could continue using Wireguard VPN setting.

    #--------------------------------------

    RTSP SERVICE REGISTRATION OVERRIDES

    #--------------------------------------
    #rtsp.register.fqdn=
    rtsp.register.host=192.168.1.** :Remove # and put in your gateway server address
    #rtsp.register.port=443


Log in to reply