Echo Show 5/8 will not show camera - "mmm...the camera isn't responding"



  • Hello,

    I have a new Echo show 5 and 8 and i cant for the life of me get them to display the camera feeds. I have got eveything working in VLC with my camera feed and setup a new UN/PW on the camera but it wont work. Tired the gateway with @tunnel, @proxy, @ noaudio, @ proxy-tcp but nothing will work.

    Here is my last feed history:

    [
    {
    “timestamp”: “2021-02-15T20:43:55.827Z”,
    “request”: “InitializeCameraStreams”,
    “response”: [
    {
    “uri”: “rtsp://%USER%:%PWD%@192.168.1.116:80/ch0_0.264”,
    “proxy”: “rtsp://61263680-c97f-4662-9130-a9d05312bcba.mproxy.io:443/STREAM:48216de8-51b7-4e01-bdbb-1ed16b226fd4?session=fd3828a2-379d-4893-83ca-3864ed4c4a65”,
    “idleTimeoutSeconds”: “60”,
    “resolution”: {
    “width”: “640”,
    “height”: “480”
    },
    “authorizationType”: “BASIC”,
    “videoCodec”: “H264”,
    “audioCodec”: “NONE”,
    “protocol”: “RTSP”
    }
    ]
    },

    And here is the last log from the gateway:

    -***------------------------------------------------
    INITIALIZE RTSP STREAM: BigTest

    • NAME : BigTest
    • LABEL : PRIMARY
    • URL : rtsp://192.168.1.116:80/ch0_0.264
    • UUID : STREAM:48216de8-51b7-4e01-bdbb-1ed16b226fd4
    • SESS : fd3828a2-379d-4893-83ca-3864ed4c4a65
    • MODIF : Mon Feb 15 2021 20:42:41 GMT+0000 (GMT)
    • TAGS : @noaudio,@tunnel

    2021-02-15T20:43:56.253Z [INFO] [192.168.1.194:43290 <SyNz6LdWd>] RTSP CLIENT SOCKET CONNECTED
    2021-02-15T20:43:56.380Z [INFO] [192.168.1.194:43290 <SyNz6LdWd>] RTSP CLIENT ATTACHED TO STREAM: BigTest (STREAM:48216de8-51b7-4e01-bdbb-1ed16b226fd4)
    2021-02-15T20:43:56.382Z [INFO] [192.168.1.194:43290 <SyNz6LdWd>] RTSP ENDPOINT SOCKET CONNECTED {192.168.1.116:80}
    2021-02-15T20:43:56.382Z [DEBUG] [192.168.1.194:43290 <SyNz6LdWd>] [CLIENT REQUEST] --> [DESCRIBE] rtsp://61263680-c97f-4662-9130-a9d05312bcba.mproxy.io:443/STREAM:48216de8-51b7-4e01-bdbb-1ed16b226fd4?session=fd3828a2-379d-4893-83ca-3864ed4c4a65
    2021-02-15T20:43:56.382Z [TRACE] [192.168.1.194:43290 <SyNz6LdWd>] [CLIENT REQUEST] --> [HEADERS] {
    “accept”: “application/sdp”,
    “user-agent”: “Fire OS/6.0 stagefright/1.2 (Linux;Android 7.1.2)”,
    “cseq”: “1”
    }
    2021-02-15T20:43:56.382Z [INFO] [192.168.1.194:43290 <SyNz6LdWd>] RTSP ENDPOINT ATTEMPTING AUTHENTICATION: BASIC
    2021-02-15T20:43:56.382Z [DEBUG] [192.168.1.194:43290 <SyNz6LdWd>] [ENDPOINT REQUEST] --> [DESCRIBE] rtsp://192.168.1.116:80/ch0_0.264
    2021-02-15T20:43:56.382Z [TRACE] [192.168.1.194:43290 <SyNz6LdWd>] [ENDPOINT REQUEST] --> [HEADERS] {
    “accept”: “application/sdp”,
    “user-agent”: “Fire OS/6.0 stagefright/1.2 (Linux;Android 7.1.2)”,
    “cseq”: “1”,
    “authorization”: “Basic U1RVOk1vbmtleTI3Mjc=”
    }
    2021-02-15T20:43:56.390Z [DEBUG] [192.168.1.194:43290 <SyNz6LdWd>] [ENDPOINT RESPONSE] <-- [200 (OK)] <cseq=1> (session=undefined)
    2021-02-15T20:43:56.391Z [TRACE] [192.168.1.194:43290 <SyNz6LdWd>] [ENDPOINT RESPONSE] <-- [HEADERS] {
    “cseq”: “1”,
    “content-type”: “application/sdp”,
    “content-length”: “247”,
    “server”: “minirtsp 2.2 (by kaga)”
    }
    2021-02-15T20:43:56.391Z [TRACE] [192.168.1.194:43290 <SyNz6LdWd>] [ENDPOINT RESPONSE] <-- [BODY]
    v=0
    o=- 1420623137 1 IN IP4 192.168.1.116
    s=ch0_0.264
    i=minisdp
    c=IN IP4 192.168.1.116
    t=0 0
    a=control:*
    m=video 0 RTP/AVP 96
    a=rtpmap:96 H264/90000
    a=control:track=video
    m=audio 0 RTP/AVP 8
    a=rtpmap:8 PCMA/8000
    a=control:track=audio
    2021-02-15T20:43:56.391Z [INFO] [192.168.1.194:43290 <SyNz6LdWd>] RTSP ENDPOINT AUTHENTICATION SUCCESSFUL: BASIC
    2021-02-15T20:43:56.391Z [INFO] [192.168.1.194:43290 <SyNz6LdWd>] RTSP ENDPOINT SDP REMOVED AUDIO CHANNEL: [PORT=0; PROTOCOL=RTP/AVP; PAYLOADS=8]
    2021-02-15T20:43:56.392Z [DEBUG] [192.168.1.194:43290 <SyNz6LdWd>] [CLIENT RESPONSE] <-- [200 (OK)] <cseq=1> (session=undefined)
    2021-02-15T20:43:56.392Z [TRACE] [192.168.1.194:43290 <SyNz6LdWd>] [CLIENT RESPONSE] <-- [HEADERS] {
    “cseq”: “1”,
    “content-type”: “application/sdp”,
    “content-length”: “181”,
    “server”: “minirtsp 2.2 (by kaga)”
    }
    2021-02-15T20:43:56.392Z [TRACE] [192.168.1.194:43290 <SyNz6LdWd>] [CLIENT RESPONSE] <-- [BODY]
    v=0
    o=- 1420623137 1 IN IP4 192.168.1.116
    s=ch0_0.264
    i=minisdp
    c=IN IP4 192.168.1.116
    t=0 0
    a=control:*
    m=video 0 RTP/AVP 96
    a=rtpmap:96 H264/90000
    a=control:track=video
    2021-02-15T20:43:56.402Z [INFO] [192.168.1.194:43290 <SyNz6LdWd>] RTSP CLIENT SOCKET CLOSED
    2021-02-15T20:43:56.402Z [INFO] [192.168.1.194:43290 <SyNz6LdWd>] RTSP CLIENT DETACHED FROM STREAM: BigTest (STREAM:48216de8-51b7-4e01-bdbb-1ed16b226fd4)
    2021-02-15T20:43:56.402Z [INFO] [192.168.1.194:43290 <SyNz6LdWd>] RTSP ENDPOINT SOCKET CLOSED [192.168.1.194:43290 <SyNz6LdWd>]***

    Can anyone help me figure out what the problem is here?

    The gateway is on a home assistant server and is running well. I have tested all the correct ports are open and listening as well.

    All Alexa says is…mmm the camera isn’t responding

    Capture12.PNG

    Thanks


Log in to reply