Unable to connect hikvision nvr to Alexa.



  • I have a hikvision DS-7608NI-I2/8P nvr. I have been following the step by step setup guide but I cannot seem to find where this is failing.

    I seem to have it almost solved. Before I add the no audio tag, it use to fail quicker. If I use the tunnel tag, it fails faster. I have got it at a point where Alexa does actually make the loading flicker. So it seems that it is connecting, then gets kicked or something. I’m not totally sure.

    I am fairly decently technically minded, but I’m thinking I might need someone to take a look at the setup remotely and confirm everything is correct. I’m not really sure what to do.

    Alexa tells me “Hmm, the camera isn’t responding”

    I welcome any information anyone might have to help me. I’m in Australia, so our timing might be quite a bit off, but I will check back every few hours. Thank you



  • @alison22000 Loop Back.
    A few people on here have previously disagreed with my loop back solution.

    Your Hikvision has an internet port which will be connected to your home router. This is how you can remotely view your images. Alexa is also connected to your router via WiFi. The problem is, Alexa cannot see your Hikvision NVR.

    SOLUTION: Connect one of the spare network ports on your Hikvision (the same ports you plug your cemeras into) to your router. This is known as “Loop back”. ie you are looping back your Hikvision into your LAN so Alexa can see it.

    The loop back definitely works (so long as the address you are using for your cameras in the Monocle app are correct).

    NOTE: Occasionally this will generate an IP conflict because some systems do not like the Loop Back. You will see 2 IP addresses on your Hikvision network page. Your Hikvision NVR actually has its own internal network. I’ll try to make another post later to explain how this works.





  • @Esso

    Thank you for replying with the information. Just so I got this right. After connecting the extra Ethernet. I port forward the new ip on my router settings for the new IP address. Then basically replace my old rtsp URL up address with the new IP address.

    Do I do anything extra with the URL string? Like changing the channels at the end or just leave them the same?

    Thank you



  • @alison22000

    Hi

    If you look in Configuration -> Network settings on your Hikvision NVR you will see two IP addresses.

    IPv4
    The top one is the IPv4 address. This is the IP address of your NVR on your LAN. This is the IP address you use when you are port forwarding from your router so you can view your cams remotely from your mobile phone.

    Internal NIC

    There is another IP address at the bottom of the Network settings page called “Internal NIC”. This is generated when you do the loop back. This is your Internal Network Interface Card.

    ACTION: All you need to do is plug a network cable into one of the camera ports on your NVR and the other end into your network router.

    The IP addresses of your cameras do NOT change but because you have connected your NVRs internal NIC to your LAN with a cable Alexa will now be able to see your cameras.

    A bit more information…

    So how do I know this? because I tried to access the web interfaces of my cameras on my LAN but couldn’t. I could access the NVR interface using the IPV4 address no problem.

    Eg, my NVR IPv4 address is 192.168.1.50. If I enter that into a Web browser on my LAN I can login to my Hikvision NVRs interface.

    One of my cams is on 192.168.1.51. If I enter that into a Web browser on my LAN I can’t access the the cams web interface.

    My NVR can see the cam on 192.168.1.51 no problem because the NRV creates its own INTERNAL NETWORK. It just so happens the IP address range of my web cam is within the same range as my LAN, but it doesn’t make any difference because it’s actually not on my LAN it is on the “Hikvisions own internal Lan”. This is exactly the same reason why Alexa can’t see the cam on 192.168.1.51. Connecting your NVRs internal NIC to your LAN with a cable solves this.

    Now when I enter 192.168.1.51 into a Web browser on my LAN the login page for my camera appears. I can then login and configure all of the settings on my camera which I cannot do from my NVR.

    Let me know how you get on.



  • @Esso
    In technical terms, your Hikvision NVR is doing subnetting. Whist you can see valid IP addresses for all your IP cams plugged into your NVR on your LAN, your NVR has its own subnet which is separately managing the cameras that are plugged into it. Your Hikvision NVR let’s you see the cams IP address but it doesn’t let you (or Alexa) connect to them.

    If you try to access the web interface of a camera that is plugged into your NVR you would be accessing it via the NVR which the camera is physically plugged into to but it won’t work because the NVR would need to route additional traffic from the LAN through itself to the camera and this is what causes the issue.

    This is also why Alexa cannot show the camera feeds. The loopback cable gets around this problem by making the cameras available directly from the LAN (because the loopback cable is plugged into the same bunch of network ports on the NVR as your cameras).

    To prove this is correct I have one camera that is not plugged into my NVR. It’s in an awkward location so I plug that camera directly into a switch that is connected to my router.

    I CAN view that camera on Alexa without using the loopback cable. I can also access the interface of that camera without using a loopback cable. This proves that cameras that are plugged directly into the NVR are not directly accessible from your local area network without using a loop back cable.

    Just thought I would mention you dont actually need to plug any of the cameras into your NVR. So long as your NVRs network port is plugged into your router you can connect cameras to the router or to a switch that is connected to your router and they will work with your NVR and you won’t need a lookback cable to access their Web interface and Alexa can also access them.



  • @Esso
    Last post tonight.

    Based on my last post, a super-quick test would be if you could unplug the cameras that are directly plugged into your NVR and plug them into your router you should be able to access them via Alexa.

    Only when they are plugged directly into your NVR will you get issues.

    And by the way, I never use the Monocle Gateway as I never leave any PCs on 24/7.

    The solution to this post is

    1 Use a loopback cable
    2 Plug your cameras into a router or switch on your LAN and not directly into your NVR.



  • @Esso I have done as you instructed and i have found the new IP address. Alexa is still having trouble. I cannot input the new IP address into a browser, it does nothing. I cannot port forward to it either as my modem says it is not a valid IP address. I will read over your instructions again to find what the next step was. Thank you




  • INITIALIZE RTSP STREAM: Inside Camera

    • NAME : Inside Camera
    • LABEL : PRIMARY
    • URL : rtsp://128.100.0.1:554/Streaming/Channels/301/
    • UUID : STREAM:e6ece47b-d461-4260-a1bb-e03fbe56fde4
    • SESS : e7427257-3be3-478d-abe3-1c594d85f1c9
    • MODIF : Sun Feb 21 2021 16:16:36 GMT+1100 (AUS Eastern Daylight Time)
    • TAGS : @noaudio,@tunnel


    RTSP STREAM MODIFIED: Inside Camera
    Any existing RTSP steams will be shut down
    and a new stream instance will be registered.

    2021-02-21T05:16:49.121Z [DEBUG] <RTSP-PROXY> [REQUEST] --> [DEREGISTER] rtsp://128.100.0.1:554/Streaming/Channels/301/
    2021-02-21T05:16:49.121Z [TRACE] <RTSP-PROXY> [REQUEST] --> [HEADERS] {
    “cseq”: “1”,
    “transport”: “reuse_connection=0;preferred_delivery_protocol=udp;proxy_url_suffix=STREAM:e6ece47b-d461-4260-a1bb-e03fbe56fde4”
    }
    2021-02-21T05:16:49.136Z [DEBUG] <RTSP-PROXY> [RESPONSE] <-- [451 (Invalid parameter)] <cseq=1> (session=undefined)
    2021-02-21T05:16:49.136Z [TRACE] <RTSP-PROXY> [RESPONSE] <-- [HEADERS] {
    “cseq”: “1”,
    “date”: “Sun, Feb 21 2021 05:16:49 GMT”
    }


    INITIALIZE RTSP STREAM: Inside Camera

    • NAME : Inside Camera
    • LABEL : PRIMARY
    • URL : rtsp://192.168.0.246:554/Streaming/Channels/301/
    • UUID : STREAM:e6ece47b-d461-4260-a1bb-e03fbe56fde4
    • SESS : a10af0b8-259a-48a8-b2f5-5f3f18d2d2ad
    • MODIF : Sun Feb 21 2021 16:21:24 GMT+1100 (AUS Eastern Daylight Time)
    • TAGS : @noaudio,@tunnel


    RTSP STREAM MODIFIED: Inside Camera
    Any existing RTSP steams will be shut down
    and a new stream instance will be registered.

    2021-02-21T05:21:33.959Z [DEBUG] <RTSP-PROXY> [REQUEST] --> [DEREGISTER] rtsp://192.168.0.246:554/Streaming/Channels/301/
    2021-02-21T05:21:33.959Z [TRACE] <RTSP-PROXY> [REQUEST] --> [HEADERS] {
    “cseq”: “1”,
    “transport”: “reuse_connection=0;preferred_delivery_protocol=udp;proxy_url_suffix=STREAM:e6ece47b-d461-4260-a1bb-e03fbe56fde4”
    }
    2021-02-21T05:21:33.959Z [DEBUG] <RTSP-PROXY> [RESPONSE] <-- [451 (Invalid parameter)] <cseq=1> (session=undefined)
    2021-02-21T05:21:33.959Z [TRACE] <RTSP-PROXY> [RESPONSE] <-- [HEADERS] {
    “cseq”: “1”,
    “date”: “Sun, Feb 21 2021 05:21:33 GMT”
    }



  • @alison22000

    Why do you keep mentioning port forwarding?

    You don’t need to port forward for Alexa.

    None of your IP addresses change.

    All you need to do is plug the loop back cable in. That’s all.

    Then use the IP address of your cameras in the Monocle app for Alexa.



  • @Esso

    I have just checked and this is the rtsp I use to access my Hikvision cam.

    This definitely works with the loopback cable. Just tested it 4 x Alexas

    rtsp://192.168.1.57:554/Streaming/Channels/101/

    I always put the / on the end.



  • @Esso I do have the correct URL rtsp://192.168.0.246:554/Streaming/Channels/101/

    I have added the cable from nvr camera port to a spare modem LAN port. There is the secondary IPv4 address in the hikvision settings.

    Alexa still fails. I mentioned the port forwarding because I’ve spent the whole day trying to find a solution. Port forwarding rules was the only additional thing I could sort, but didn’t help.



  • @alison22000

    In the example I gave, the. 57 is the IPv4 address (but I will check this).

    The 101 on the end of the rtsp is cam 1 stream 1

    So 201 on the end is cam 2 stream 1

    You have 301 so that’s cam 3 stream 1

    cam 1 stream 1
    rtsp://192.168.1.57:554/Streaming/Channels/101/

    cam 2 stream 1
    rtsp://192.168.1.57:554/Streaming/Channels/201/



  • @Esso
    Below is the rtsp you had in your sample

    rtsp://192.168.0.246:554/Streaming/Channels/301/

    So you are trying to view cam 3 stream 1.

    Is the .246 your IPv4 address? (ie the IP address of your Hikvision NVR on your LAN?).

    I’ll confirm the .246 should be your IPv4 address.



  • @Esso I have 8 different cameras. 101 to 801. Yes the IPv4 address for the nvr system is 192.168.0.246. None of them are connecting.



  • @Esso Hi does this setup with the loop back work on DVR’s with the BNC connections?

    Many thanks



  • @Tonza1
    BNC ey…

    It’s the NVR that sends the streams to Alexa rather than the actual cameras so it MIGHT work with BNC cams.

    That’s why the Monocle app only needs the IP of the NVR and then the camera number on the end to sure the feeds

    Ie 101 on the end is Cam 1 Feed 1

    What is the make and model of your NVR?



  • @Esso I have a Hikvision DS-7204HUHI-K1 DVR 4 channel which I think only has 1 Lan port. I have set up the rtsp and it works fine via VLC through a laptop. I’ve successfully added the cameras to the Amazon App and it recognises my cameras but when I ask Alexa to show me the camera she says “ok” then after a few seconds says “hmmm the camera isn’t responding”



  • I also have mine set up correctly. Even with the loop back connected. I can view in VLC. But Alexa cannot find it. I was also told I could plug my camera directly into my modem, but my modem is a modem and router in one unit and doesn’t support PoE, so the camera won’t work. I am getting a PoE switch, but I need to find how to set everything correctly up through that. Hopefully this switch will resolve everything.



  • @alison22000 I don’t have a spare port to plug in a loop back cable so that’s not an option for me. Alexa goes to open the cameras and the screen flickers but then fails. Not actually sure what’s wrong.


Log in to reply