RTSP CLIENT SOCKET TIMEOUT



  • Hi,
    Camera model : XM530_R80X20-PQ_8M (chinese cam)
    Echo show 8
    Gateway on windows 10 64bits

    Hi,
    I’ve been through all the steps, following your guides :
    Added RTSP url of cam in my account, stream tested on VLC, works great, video codecs are ok, audio are not but I added @no_audio tag to cam account. Added alexa skill, and then running gateway => ok
    So, i can see the cam on alexa’s app.
    I ask the cam to show on echo 8, and I see the gateway is stuck on this :

    2021-02-21T12:30:24.328Z [WARN] [192.168.1.37:48346 <r15BG0yfO>] RTSP CLIENT SOCKET TIMEOUT
    2021-02-21T12:30:24.336Z [WARN] [192.168.1.37:48346 <r15BG0yfO>] RTSP ENDPOINT SOCKET TIMEOUT [192.168.1.37:48346 <r15BG0yfO>]
    2021-02-21T12:30:24.337Z [INFO] [192.168.1.37:48346 <r15BG0yfO>] RTSP CLIENT SOCKET CLOSED
    2021-02-21T12:30:24.339Z [INFO] [192.168.1.37:48346 <r15BG0yfO>] RTSP CLIENT DETACHED FROM STREAM: cam 5 (STREAM:4f13e2c0-87b3-4acc-a233-b1427d111c07)
    2021-02-21T12:30:24.340Z [INFO] [192.168.1.37:48346 <r15BG0yfO>] RTSP ENDPOINT SOCKET CLOSED [192.168.1.37:48346 <r15BG0yfO>]

    After 4 or 5 tries, alexa says the cam is not ready or not available.
    I followed all the troubleshooting guide, disabled firewall both on my PC (hosting the gateway) and in the router.
    443 port is free on my PC, but in my router is configured to route to my raspberry. Anyway, I tried to delete this routing on my router, no effect, so may not be the culprit.

    I have no more ideas…
    thanks



  • @paulbiod
    Also, checked my history, and grab the rtsp url and tried it on vlc, works fine…



  • Well, We can see how much support we are getting here, this whole thing seems completly abandonned, no tech support, nothing. shame



  • @paulbiod you have certainly gotten what you have paid for, then.

    This looks like a community forum more than a direct support forum from the developer, so perhaps more patience will be necessary until another user figures out the solution and chimes in.



  • @paulbiod said in RTSP CLIENT SOCKET TIMEOUT:

    . Anyway, I tried to delete this routing

    Based on the log info posted it seems like your Monocle Gateway is working. It appears that your Echo Show 8 is attempting to connect to the camera stream but is immediately terminating the RTSP connection. This is a common behavior when the Alexa device REJECTS the RTSP stream. Unfortunately Alexa does not provide us any details on why she does not like the stream – even when its a perfectly playable stream in FFMPEG and VLC.

    So all we are left with is shooting in the dark and trying to find some combination of settings that make Alexa happy. I would suggest trying the tags @fakefmtp,@noaudio,@tunnel or @fakefmtp,@noaudio,@proxy

    443 port is free on my PC, but in my router is configured to route to my raspberry. An

    No externally exposed ports are needed for Monocle Gateway. Monocle Gateway connects outbound to a Monocle Web Socket server to get notified of Alexa requests and then Alexa devices connect to the Monocle Gateway locally inside your network.

    Thanks, Robert


Log in to reply