New Echo Show Issues [SOLVED]



  • Hi all,

    I just purchased the Echo Show so I can view my Hikvision camera though it. I think I have set everything up correctly as I can see my camera using VLC as per the instructions, my issue starts when I ask Alexa to show me the driveway, she agrees and then I just get “waiting for driveway” and then “buffering…” I read somewhere that the Show can only do 720p so I went into the camera setting and changed from 1080p to 720p but this did not solve my issue.

    Any ideas are greatly appreciated.

    I should mention that after a few more tries I at least get a blurry view of my driveway with “buffering…” shown on the bottom. If I ask her to play something from Amazon Video it works fine. (Hikvision DS-2cd2142FWD-IS).

    “timestamp”: “2019-07-16T22:59:53.503Z”,
    “request”: “InitializeCameraStreams”,
    “response”: [
    {
    “uri”: “rtsp://%USER%:%PWD%@192.168.1.XXX:554/video.h264”,
    “proxy”: “rtsp://proxy.monoclecam.com:443/6c2626d1-5899-40ad-bf01-8ab280630d39”,
    “resolution”: {
    “width”: “1280”,
    “height”: “720”
    },
    “authorizationType”: “DIGEST”,
    “videoCodec”: “H264”,
    “audioCodec”: “AAC”,
    “protocol”: “RTSP”
    }
    ]



  • @studlygoorite

    Which Echo Show version? The new Echo Show 5? Or a Gen1 or Gen2 Echo Show? (I know the names are confusing … way to go Amazon!)

    Thanks, Robert



  • Sorry, Echo Show Gen 2, also, the blurry view of the driveway is not a live shot, it’s from yesterday.



  • @studlygoorite

    The Echo Show (gen 1 & gen 2) can support cameras streams up to 4K. So the resolution should not be an issue. Let me test a Hikvision camera on my Echo Show Gen 2 and see if its still working here. I have seen some buffering issues like you describe on a Reolink camera since the latest system updated on the Echo Show Gen2 that came out about a week ago.



  • @Monocle Have you had a chance yet?



  • @studlygoorite

    Sorry for the delay, I got distracted then was traveling for several days. I just tested my Hikvision camera successfully on the following:

    • Echo Show (Gen 1)
    • Echo Show (Gen 2)
    • Echo Show 5
    • FireTV 4K
    • FireTV Cube

    Here is my camera configuration in Monocle Web Portal:

    63133e50-e2cb-40df-94a8-363f0df92634-image.png

    (Note, the @tunnel tag is used/required with Monocle Gateway for the FireTV and Echo Show 5 devices.)

    Here are my camera’s settings:

    f8237096-8322-4f05-9eff-10fe5b447d3a-image.png

    a71b6047-79e7-4adf-b7ff-c0e768dcd132-image.png

    I hope this helps!

    Thanks, Robert



  • Also, it never hurts to reboot both the camera and Alexa devices when in doubt 🙂

    Thanks, Robert



  • All settings looked good but no go, saw your added comment to re-boot and…BINGO, I have a camera feed. Thanks Robert. Can’t believe I didn’t do that already, I always tell everyone else that I know that have issues like this to re-boot. Sorry to waste your time but thanks again.



  • @studlygoorite

    Glad its working now! For some reason once these Alexa devices get into some state where they won’t connect, many times they require a reboot to re-connect successfully. Who know why?

    Thanks, Robert



  • All of a sudden I have to re-boot the camera every day now or the show just buffers the stream. IP address is the same, anyone have any idea what might cause this?



  • @studlygoorite

    No idea. I almost never have to reboot this Hikvision camera. (unlike some others I have.)

    Although, I do allow most of my cameras to do a maintenance reboot daily. I’ll have to check this Hikvision and see if its setup for a daily reboot.

    Thanks, Robert


Log in to reply