Works with Show directly but buffers with gareway



  • I have 4 IP cameras working great on Alexa Show 2nd gen directly. 3 Samsung and 1 Dahua. However I wanted to make the cams to work on two Fires - cube and stick 4k latest gen. With gareway all worked on Fire but one.
    The bigger issue however is that Show now works for 10 sec than starts buffering and closes. Same for all cameras with either @tunnel or @ proxy tags.
    As soon as I remove tags all working again solidly on Show.

    Gateway is running on dedicated laptop windows 10 as service, on eithernet. All cams are useing downgraded resolution streams limited to 1080. They also stream to Synology Nas without hickups. Only One camera uses audio



  • @tomsoyer

    OK, thanks for all the detail. What you have described certainly sounds like the Monocle Gateway is the bottleneck; however, we have not seen this behavior before. Can you share the log from Monocle Gateway from the point where you request a single stream to the point that it ends?

    Thanks, Robert



  • I can’t locate the monocle-gateway.log file anywhere on this PC. Service is up and running. Do I need to set something else to generate the log?



  • @tomsoyer

    It should be sitting next to the executables wherever you installed them?

    If not, stop the service and just run the executable manually from a command window and then you can copy and paste the live output text from the console window.

    Thanks, Robert



  • This post is deleted!


  • @tomsoyer any ideas?



  • @tomsoyer

    I did notice one small thing, the gateway is removing the audio channel. I’m not sure why its getting removed, I don’t see the @noaudio tag for this camera. What manufacturer/model camera is it?

    Thanks, Robert



  • Samsung SND-6084N bullet. It has no built-in audio. Audio in is disabled in the stream settings. I have the same problems with other cameras. I have Dahua N44CG52 with audio and same issues. I tried to disable audio in the sub stream with the same results. I didn’t notice that gateway uses excessive PC resources. Laptop used to be Plex server and was handling it just fine. I can’t imagine gateway in tunnel mode uses much resources. One thing that bothers me is that I’m not getting log generated. May be I’ll try temporary install gateway on my main PC to see if that works.



  • @tomsoyer

    FYI, generate a new Monocle token for testing on your PC, else they will both compete for the same DNS hostname.


Log in to reply