"Hmmm, the camera isn't responding"

  • Alexa: “Hmmm, the camera isn’t responding”

    NVR: Hikvision NVR (actually Luma branded 510 series - newest model)
    Cameras: Hikvision 4k domes (actually Luma branded 710 series - newest models)

    Setup and tested via VLC - worked.
    Setup Alexa skill and tested via Echo Spot - worked.
    Tested via Echo Show (2nd Gen 10") - worked.
    Then cloned the working camera feed to attempt to get other cameras working.
    At this point the working camera feed ceased to work on any Echo device and none of the new camera feeds worked either.

    (NOTE: works perfect via VLC)
    Last Viewed:Mon Sep 02 2019 21:14:00 GMT+0000 (UTC)
    DIGEST / H264 / NONE / 192*192

    What I’ve tried:
    Every possible and suggested setting on the NVR and the Cameras - no change
    Every suggested setting on the Monocle setup
    Deleted Monocle account and recreated it
    Deleted Monocle Alexa skill and then re-enabled it

    Why my brain is fried:
    This WAS WORKING with one camera feed on both Echo Spot and Echo Show (2nd Gen 10")
    Now no matter what I try, I just get “Hmmm, the camera isn’t responding”
    Meanwhile it works perfectly in VLC and VLC reports as to the Codec Details:
    H264 MPEG-4 AVC (part 10) (h264)
    Video resolution: 704x576


  • Sorry to bump, but anyone out there who could weigh in and help - would be most appreciated.

  • Sorry for the delay. I’m mostly out of the office until the end of the month but am checking in at random times on the forum to try and help. It’s difficult to say what’s going wrong in this case. There is very little visibility into why Alexa fails to display a stream. In the monocle web portal you can view your camera feed history to see what RTSP address was sent to Alexa just to make sure it looks correct.

    You might try rebooting Alexa. I know this sounds cheesy, but after several stream fails, I have experienced issues where restarting Alexa got it working again.

    I’m guessing you have already been through these tips and tricks:

    Beyond that, my next suggestion would be to install the Monocle Gateway and setup your cameras to use that. At least with this installed, we can capture the logs and get a better understanding of where in the process it seems to be failing. https://monoclecam.com/monocle-gateway


  • @anon2828 said in "Hmmm, the camera isn't responding":

    Hi Anon2828,

    I can across your post and was having the same exact issue, except I am using Q-See cameras. I had to use the gateway in order for it work. This is what I discovered thus far:

    1. If you are using a NVR/DVR and have your security cameras behind it using the builtin switch of the DVR or NVR, you can only stream one camera that is associated with the DVR/NVR. No other cameras behind the DVR/NVR IP address will stream. However, if you move the other cameras on the same network as the Alexa you should be able to stream all cameras.
    2. Make if you are using the gateway that you have a static IP address and port 443 is forwarded to this static of the gateway.
    3. Make sure you are using H264 compression
    4. Make sure the gateway service is running according to the documentation.
    5. Make sure Alexa sees the camera in the list of the Alexa app.

    As I mentioned I was having the same issue but was able to resolve by checking these parameters.

    Maybe you can help me or someone else can help me as well. I am able to view the cameras successfully from:
    -Fire Cube
    -Fire Stick

    I am having trouble with FireStick 4K and Alexa Spot. I receive a message that the Spot can not find that device. The Firestick 4K does not respond with anything.

    I hope I was able to help you or someone in the future in the same situation. This is a great service!!!

  • @priobe
    Okay funny as soon as I was done writing the above, I set the tagging to @proxy and it worked 1 time. Then after that I am not getting “Okay”“I am not sure what went wrong” immediately.
    I changed the tagging back to @tunnel , restarted the gateway and still no luck.

    I guess I have to look into what happen here. If anyone has any suggestions I am open.

  • @priobe

    Try adding the @hangup tag in addition to @proxy. This will force the gateway to make new sessions for each request; otherwise, it will try to re-use an existing session for several minutes after a previous session was in use.

    If that does not help, you can also try swapping @proxy with @proxy-tcp.

    Thanks, Robert

  • @priobe said in "Hmmm, the camera isn't responding":


    1. Make if you are using the gateway that you have a static IP address and port 443 is forwarded to this static of the gateway.

    FYI, no port “forwarding” should be needed. Meaning you should not need to expose port 443 on your router to the Internet. Yes, port 443 of the gateway must be accessible by the Alexa devices on your local network so its important to check to make sure no firewall is blocking access to port 443 on the gateway.

    I am having trouble with FireStick 4K and Alexa Spot.

    Alexa Spot is limited to 1080p. Make sure any camera stream you try to use are streaming at 1080P or lower (via the camera’s settings, not Monocle settings.)

    Not sure on the FireTV 4K Stick. I’ll re-check mine and make sure its still working for me. Check to make sure its on the correct WiFi network and not on a “Guest” network or anything like that. Check to make sure the Alexa profile is using the Amazon account configured with Monocle. (you can ask Alexa to switch profiles if you have multiple profiles configured)

    Thanks, Robert

  • Based on priobe’s comments I thought I had an “ah-ha” moment - perhaps only 1 of my 6 cameras would work with Monocle when connected through the DVR as priobe mentioned. I was only testing with one camera.

    So, I went through and added my 5 other cameras. Then I attempted to call them up through Alexa one by one, hoping that I would hit on the one camera that CAN be seen through the DVR using Monocle.

    Alas, none of them work.

    So next question. My home network is on the 10.10.10.XXX space. This includes the DVR. The IP cameras themselves are on a private network within the DVR and have the 192.168.254.XXX space. I know I can change the IP address of each camera within the DVR interface. Is it possible - WITHOUT BREAKING OTHER THINGS - to assign each camera to the 10.10.10.XXX network space behind my router / firewall to see if then I can address each camera individually within Monocle as opposed to the DVR??

    Please advise.

Log in to reply