UCAM247 cameras not working on Echo Show 5 via Monocle/Monocle Gateway [SOLVED]



  • So I’ve been using Monocle for quite some time now to display my UCAM247 Cameras on my original Echo Show.

    Before Monocle came along, there was no way to view these cameras on the Echo device so it was great for there to be a way to do so. It was incredibly simple and I couldn’t be happier. I was also able to set my dad up using the same camera but using his Echo Show Gen 2 (with the 10.1 inch screen) and that too worked really well.

    I also have/had an Echo Spot which worked fine with the original Monocle skill. The shape and size of the screen wasn’t ideal for viewing cameras really but it was nice to have the option when it was needed.

    However, due to a widespread issue with the Spot, it was returned and in its place I ordered an Echo Show 5. This would replace the Spot on my bedside table and with screen better suited to viewing cameras, it seemed like a perfect replacement.

    However, once setup, my first port of call was to test the camera feed. Of course with Monocle already being live on my Echo devices throughout the home already, I just had to request to see the camera of choice. Doing so, resulted in a pulsing screen and Alexa responding with “Sorry, the camera isn’t responding”.

    Checked to ensure it was still working on the Spot (pre return) and the Show Gen 1, which it was and then of course went on to the internet and discovered information about others having similar issues with the Show 5 and the new Monocle Gateway.

    So I have had a play with the Gateway, and as of yet, I am unable to access any of my pre existing cameras using the Show 5. I have setup the Gateway on an rPi on the same network, and although the original Echo Show (gen1) worked fine without the need for the gateway, I tested some of the tagging options to see how they worked.

    @tunnel didn’t work the the gen 1 Show but @proxy did. This was a hopeful start, but alas when trying it on the Show 5, I still got the same response.

    I then tried all of the tagging options as per the instructions but none of them gave any different response to the one I got originally.

    I am not sure if the resolution of the Show 5 is the issue (I have also tried lower res streams) or if its the newer software that comes on it.

    I also have an Echo Show 8 arriving tomorrow (which was initially going to replace my Echo Show gen 1) but if i am unable to access my existing cameras on the newer device, I amy have to rethink things slightly. This of course may still be an issue if Amazon release a software update to the gen 1 at some point anyway I guess.

    I will report back when the Show 8 arrives to see if the result is the same as the Show 5.

    one point worth mentioning, I am using the standard RTSP h264 feed from the UCAM cameras. This works on all other dual methods, ie VLC and similar. I appreciate things may well need some work and if anyone can suggest any changes I might make to get things working it would much appreciated.

    Thanks in advance



  • Re: No joy with UCAM247 cameras on Echo Show 5

    Replying as myself on a new account as I don’t seem to have access to my original account

    I can now confirm that I can access my UCAM247 cameras on both my Show 5 and Show 8

    When I first tried using the gateway running on my rPi, it didn’t work regardless of which tags I tried using.

    Upon further reading, I found out about DNSbinding causing some issues and my route was running DDWRT and had DNSbinding disabled.

    Once I had sorted this I can confirm that the @tunnel tag works fine and all of my cameras are working well

    To be honest, my fix was to disable the DNSbinding block on my router which probably isn’t the best way to do it so will look into putting the proper fix on place.

    Thanks to the MonocleCam team for getting the gateway working and allowing us to use the new devices (that Amazon won’t).

    I can confirm I can also see the same feed fine on my FiteTV Second gen (voice controller)



  • @Jouster-74

    Thanks for confirming it’s working for you now!

    -Robert


Log in to reply