Dahua SD42212SN-HN 2MP 12X Optical Zoom PTZ Dome (SD42212SN-HN), Alexa says it's not responding.



  • Re: Synology Surveillance Station

    I’ve followed all the steps above to the letter and can’t seem to get it to work. Tried every variable I can think of with the guidelines above.

    ECHO Show 8
    DS918 Plus (using Surveillance Station for camera)
    Dahua SD42212SN-HN

    Please help! Don’t know what I’m missing.



  • Have you tried using the new gateway. Newer devices (specifically the 5 and 😎 won’t work without it



  • @Jouster-74 Please for give me for not understanding. What do you mean by new gateway? Kind of new to this as far as Alexa/Echo goes. Do you mean there is a newer version of the Monocle gateway.



  • to my knowledge, it’s newer devices like the 5 and now the 8 that have necessitated the gateway.

    in order to use a non supported camera on the 5 and 8 you’ll need to use the gateway (i call it. we as it’s. ew to me but i appreciate its been out for sometime now)



  • @Jouster-74 Again, I apologize if I seem ignorant. Just to make sure I understand, there should be a newer Alexa skill for the Monocle gateway? If it’s not that, how would I get the new gateway to work with Alexa? I’m a little confused, doesn’t take much for me to be confused.



  • there is no new skill. the gateway is required in addition for these newer devices.

    it’s all explained on the forum and portal.



  • @Jouster-74 Oh, ok. Thank you for your patience. I’ll do some digging and reading for the forum and portal.



  • @jdprock Jouster , thanks for your help. Unfortunately, nothing worked for me. Went went through the whole thing forward and backwards, even have it working with VLC without any issues. Verified that camera and Synology NVR are both supported.Maybe it’s just not supported yet with the Echo Show 8. Anyways, thanks again. I’ll probably try and reach out to Amazon next.



  • @jdprock i can confirm it’s certainly working via the gateway on the Show 8 (and Show 5), at least on my cameras of choice (UCAM247)

    what are you running the gateway on? are you leaving it running the whole time (you can’t turn it off once setup as it won’t work)

    have you tried all of the tagging options?

    also, what router are you using? there is something called DNSBinding (which i don’t fully understand if honest) but it can stop the gateway being able to communicate with your Show and mean that the feeds wont work either. this final part was what tripped me up originally. in my router OS i was able to disable DNSbinding and then it worked. i do need to bypass it it though rather than shut off fully to make it right



  • @jdprock

    There was a SSL certificate issue yesterday causing lot of problems. Please try it again now and see if its working for you. The Echo Show 8 may require using the Monocle Gateway as the Echo Show 5 does … I have not confirmed it, but I would sort of expect the same behavior as the 5" model.



  • @Monocle I can confirm the Show 8 is excatly the same for my own cameras and therefore has to go through the Gateway. Without the Gateway, the repsonse from the Show 8 was the smae andno camera feed could be seen



  • Good morning @Monocle,

    I was able to successfully register, thank you. I continue to have another problem though. I am trying to setup a gateway using Docker on a Synology NAS. I get through most of the process, but when I go to run the command, sudo docker-compose up --detach, I get the following error.

    jdprock@JDPcloud:/volume1/Monocle$ sudo docker-compose up --detach
    Password:
    Starting monocle-gateway … error

    ERROR: for monocle-gateway Cannot start service monocle-gateway: b"Bind mount failed: ‘/volume1/monocle’ does not exists"

    ERROR: for monocle-gateway Cannot start service monocle-gateway: b"Bind mount failed: ‘/volume1/monocle’ does not exists"
    ERROR: Encountered errors while bringing up the project.
    jdprock@JDPcloud:/volume1/Monocle$

    Any ideas??



  • @jdprock

    It looks like your “monocle” shared folder is using an upper case “M” at the beginning. The Synology file system is case sensitive. Please try renaming the shared folder to use all lower case letters.

    Thanks, Robert



  • @Monocle Thank you Robert. That did the trick to successfully run the script. The Monocle Docker service/container starts and the network gateway is connected. I have added the tag @tunnel and even tried all of the various tags for good measure, but when I go to execute the camera through echo, it fails and says the camera is not responding. Here is the container log. I sure appreciate your help. Stuck again. I have also included a screen shot for quick reference. Thank you so much for your help.
    bfb02037-132c-4d59-9e78-298e75dc1a1c-Screen Shot 2019-11-30 at 1.38.58 PM.png
    Screen Shot 2019-11-30 at 1.38.58 PM



  • @jdprock

    Based on this log, it looks like the Docker instance is not able to access the camera over the network at 192.168.1.228:554. So this is likely some Docker networking related issue where the docker instance is not able to access nodes on the private lan. The docker instance is clearly communicating with the Internet, so it not like its not connected at all, but is there a VLAN or anything that would prevent it from accessing nodes on the local network?

    Thanks, Robert



  • @Monocle Though maybe it was my VPN for when I download torrents, no such luck. Turned it off, restarted everything and came up with the same results in the log. Going to look at the router (also Synology) and try and dig deeper.

    Thank you once again for your help. I know just enough about networking to get myself in trouble!


Log in to reply