Synology Surveillance Station



  • Synology Surveillance Station


    ✔ The camera feeds on this NVR are confirmed to work with Monocle and Alexa when also using the Monocle Gateway service. (See below for more details.)

    0_1538612468178_Synology-Surveillance-Station-8.jpg


    MONOCLE GATEWAY:

    This camera requires using the Monocle Gateway service.

    There is an incompatibility in the camera streams hosted by the Synology Surveillance Station that prevents Alexa from playing the stream directly. However, using the Monocle Gateway service and tagging these camera streams with the @proxy tag allows these stream to work with your Alexa devices.


    SETUP INSTRUCTIONS:

    First, open the Synology Surveillance Station web portal on your Synology device. From the Desktop or from the Menu, open the IP CAMERA utility.

    0_1538613082326_synology-ip-camera.png

    Next, find the camera that you want to stream and right-click the camera row and select the “Share stream path” option from the popup menu.

    0_1538613431513_synology-select-camera-share.png

    Now, set the “Duration of validity” field to “forever” and then copy the value from the RTSP text box.

    0_1538613782801_synology-share-stream.png

    The RTSP URL may look something like this:

    rtsp://syno:7434e7fa0354d5c3ca923cb6136302@10.1.1.3:554/Sms=2.unicast
    

    This RTSL URL is in the following format:

    rtsp://{username}:{password}@{ip-address}:554/Sms=2.unicast
    

    You would enter this RTSP URL and access credentials into the Monocle Web Portal as illustrated in the example screenshot below. Please note the @proxy tag in the TAGS field as well - this is what instructs the Monocle platform to route requests for this camera stream to your Monocle Gateway service instance.

    0_1538614181813_synology-monocle.png

    Finally, ask Alexa to show your camera stream.


    RESOURCES:



  • Hi, I’ve got a few questions to the last screenshot.
    You set the authentication to digest, but isn’t Synology using Basic?
    And you set the Audio Codec to AAC while VLC display that Synology is using PCM ALAW which should be G711?



  • @pattyland

    You may be right on the authentication. However, it should work with either setting. If you choose “DIGEST” we attempt DIGEST authentication first if possible and revert to BASIC if DIGEST is not available or fails. If you choose “BASIC”, we attempt BASIC authentication first unless we receive information in the request/response headers that indicate that the endpoint requires DIGEST. So this authentication setting really should work with either value, perhaps just more optimized if its set correctly.

    Ås for the audio codec, maybe that depends on the actual camera stream that Synology is attached to. I’m not 100% sure, I’d have to set it up again and test. I know my cameras attached to my Synology NAS are producing AAC audio streams, but I’m not sure if Synology transcodes the audio to G711. This audio codec setting provides guidance to the Alexa devices as to which type of audio stream to expect; however, in practice I’m not sure that it matters too much as it seams Alexa will accept either one at runtime and not reject the stream outright if this setting is incorrect. It is a good idea to set it correctly if you know its wrong, because perhaps there is more at play than we realize in side the black-box that is Alexa.

    Thanks, Robert



  • @Monocle I’ve been trying to set the up to cameras in my synology surveillance station for the better part of 6 hours, and need some guidance. I’m happy to make a $100 donation if we can get this running on our Echo Show 8. I keeping getting “Sorry camera is not responding” to voice invocations to Alexa…to ES8.

    I’ve created the camera feed in my dashboard, and followed the steps for the RTSP stream from my camera on the surveillance station. The link works in VLC player just fine.

    What am I missing. Is configuring camera feeds in my dashboard, the same as mentioned Monocle gateway? Or am I missing a step. Do I need to delete the cameras from devices in Alexa and unlink/relink the skill each time to test? I followed the steps to a T. It should be working .



  • @mattman said in Synology Surveillance Station:

    @Monocle I’ve been trying to set the up to cameras in my synology surveillance station for the better part of 6 hours, and need some guidance. I’m happy to make a $100 donation if we can get this running on our Echo Show 8. I keeping getting “Sorry camera is not responding” to voice invocations to Alexa…to ES8.

    I’ve created the camera feed in my dashboard, and followed the steps for the RTSP stream from my camera on the surveillance station. The link works in VLC player just fine.

    What am I missing. Is configuring camera feeds in my dashboard, the same as mentioned Monocle gateway? Or am I missing a step. Do I need to delete the cameras from devices in Alexa and unlink/relink the skill each time to test? I followed the steps to a T. It should be working .

    Having a similar issue.

    I have 1 RTSP cam setup on my Synology Surveillance Station.
    Followed the above guide, added cam to Alexa, but I can not view cam either via Echo Show or FireTV
    Also tried changing Authentication from DIGEST to BASIC.

    I keeping getting “Sorry camera is not responding” when I ask Alexa to show/display cam

    any fixes or advice?


Log in to reply