Just wanted to say thanks! Hikvision, Show 5 and Synology setup



  • I know a lot of effort goes into getting something like this off the ground and running and then providing support. So thanks Monocle team!

    So it took a bit of effort but i finally have all 8 of my 8mp Hikvision camera’s running on this via the gateway on my Synology NAS.

    A couple of bit which may help others outside of the guide:

    The gateway on my Synology kept getting the ping timeout error - I had my NAS setup with a bond on both my ethernet - but it was set as load balance. I changed it to link aggregation and I could then ping my FQDN.

    Next issue was the DNS binding - I have an ASUS WRT Mesh setup - my NAS is on a second node not using DHCP - which I had to setup to use the Google DNS.

    After all that i still couldnt get any of the camera’s from Surveillance Station to work - 404 file not found error - even though the streams worked on VLC. Gave up and just connected directly to my Hikvision camera’s internal IP - using stream 2 at a lower resolution and H264 and that allowed me to keep H265+ for my Surveilance Station Recording - to save space on the NAS.



  • I’m running into similar issues with not being able to get Alexa to show the stream from the Surveillance station and am intrigued by your idea of connecting directly to the camera’s internal IP. Would you be able to share specifics on how you did that?

    For example, in Surveillance station the stream for my camera is: rtsp://192.168.1.26:554/Sms=2.unicast

    192.168.1.26 is my Synology server
    192.168.1.49 is my IP camera on port 80

    What address do I need to plug into Monocle to make this direct connection? What port should I be using? Finally, will I then be using the username and password for my camera directly as opposed to either the username and password for my Synology NAS or the one provided by Surveillance station in the streaming section “rtsp://syno:abcd1234@192.168.1.26:554/Sms=2.unicast”?

    Your insights would be very much appreciated, thanks!



  • @Auspician

    Hi,

    For each of my camera’s i setup a new user account for monocle, then generated the rstp feed.

    Then i setup my monocle using the camera rstp feed using the new username and password with the @proxy tag.

    I used stream 2, and i had to set it to H264. I struggled for ages to get it to work… turned out the camera’s were on H265+.



  • Thanks for the quick reply! I’m a bit confused… you are saying that you gave each camera it’s own monocle account, then used the monocle account itself as the username and password for the stream? Where did you generate the rstp feed from if not Surveillance station? Did this source automatically assign the correct port?

    I obviously don’t understand how this works well enough to understand how monocle can connect to your cameras using monocle’s own password… how then is camera access authenticated?



  • @Auspician

    Just took one of my feed url’s they look like this:

    rtsp://192.168.1.200:554/Streaming/Channels/102



  • @Auspician

    Found this as a guide of getting the rstp of your camera.

    http://www.cctvwholesales.co.uk/blog/hikvision-rtsp.html

    The rstp port can be found by logging into your camera and then settings, network, basic settings, port

    And you should see the rstp port there



  • Thanks for the help, I was able to figure out my direct rtsp streams for each of my cameras. My next issue is how to properly setup the Monocle configuration, particularly in regards to tags. When connecting directly to your cameras, what tags did you need to use?



  • @Auspician

    I only needed to use the @proxy and it worked!

    Originally for a firestick it worked even without the proxy… but my show5 needed the proxy.



  • This has gotten me closer; when I try to connect to the RTSP stream from Surveillance station it fails almost immediately (404 not found error in the monocle-gateway log). When I try to connect directly to the stream from my Reolink cameras, it struggles, tries, and still ultimately fails. Where I go into the monocle-gateway logs it gives me code 200 (OK) and says it is playing (RTSP CLIENT PLAYING MEDIA STREAM). But it doesn’t actually display or show up on my Echo Show. Any ideas?



  • @Auspician

    Sounds like its connecting - just cant play.

    What compression and resolution is the video footage?

    needs to be h264 and a lower resolution.



  • I am setup at H264, but the camera records at 2560 x 1920. Am I able to select a lower resolution in Monocle that doesn’t match what the camera is actually recording at? Maybe just matching the aspect ratio? I can get the camera to record at 2304 x 1296 at the minimum setting, if that makes a difference.



  • @Auspician said in Just wanted to say thanks! Hikvision, Show 5 and Synology setup:

    I am setup at H264, but the camera records at 2560 x 1920. Am I able to select a lower resolution in Monocle that doesn’t match what the camera is actually recording at? Maybe just matching the aspect ratio? I can get the camera to record at 2304 x 1296 at the minimum setting, if that makes a difference.

    Which Alexa device are you using? Some devices are limited to 1080P resolutions. Most camera’s offer a secondary stream at a lower resolution – you might try that.

    Thanks, Robert



  • @aquazi said in Just wanted to say thanks! Hikvision, Show 5 and Synology setup:

    I know a lot of effort goes into getting something like this off the ground and running and then providing support. So thanks Monocle team!

    So it took a bit of effort but i finally have all 8 of my 8mp Hikvision camera’s running on this via the gateway on my Synology NAS.

    A couple of bit which may help others outside of the guide:

    The gateway on my Synology kept getting the ping timeout error - I had my NAS setup with a bond on both my ethernet - but it was set as load balance. I changed it to link aggregation and I could then ping my FQDN.

    Next issue was the DNS binding - I have an ASUS WRT Mesh setup - my NAS is on a second node not using DHCP - which I had to setup to use the Google DNS.

    After all that i still couldnt get any of the camera’s from Surveillance Station to work - 404 file not found error - even though the streams worked on VLC. Gave up and just connected directly to my Hikvision camera’s internal IP - using stream 2 at a lower resolution and H264 and that allowed me to keep H265+ for my Surveilance Station Recording - to save space on the NAS.

    Thanks for the kind words and providing some useful info to other/future readers!

    Thanks, Robert


Log in to reply