NB2 Nelly's Security Doorbell Camera /EZVIZ

  • Hi wondering if there is anything I can do to further troubleshoot the issue. I verified my URL and tested with VLC. I can see in logs that my Alexa show is trying to access but log only shows request and no errors. The Alexa simple says the camera is not responding.

    Not sure what else to try here?

  • have you tried the Gateway?

  • I recently bought the EZVIZ DB2 and installed their Alexa skill. Even though the skill description doesn’t include the DB2 as a supported camera, I can stream to the Echo Show and save video streams to my Synology Surveillance Station through a user defined RTSP connection setup. I originally tried flashing the camera with the Nelly’s firmware to use their ONVIF functionality, but I couldn’t stream to the Echo Show. Didn’t try the Monocle skill as that have not worked in the past. My understanding is that the DB1 will be supported in the next Gateway beta release (0.0.5?) which supposedly was coming out months ago. Not sure if the DB2 will be supported as well.

  • @avaledon That’s great to hear. I installed the skill and linked my EZVIZ account but the doorbell was not discovered. Do you have to be on local LAN when you do discovery? Or is there a setting/sharing that needs to be enabled in settings?

  • @Jouster-74 I had it installed on my windows server but not sure if it was setup correctly. Will give it a try again if I can’t get EZVIZ amazon skill working.

  • @redcaesar Local LAN is all you need. I did notice it takes a while for the camera to be recognized by Alexa though. Tried it a few times and was getting a “camera not found” message from Alexa, but was recognized a bit later.

  • @redcaesar Ive run mine on an rPi3…woudlve run it on my Synology NAS but mine isnt Docker compatible

    Even if you have no kit it works on, in my opinion, its worth buying an rPi for, especially as they are so cheap

  • @avaledon Hi still having issues with getting this to work I followed instructions. Set a name for camera in EZVIZ app and disabled image encryption. Then thorough Alexa enabled the app and linked EZVIZ account. Alexa searches and does not find device. Waited few hours and still nothing showed up. I did this all from same LAN/SSID as camera and Alexa.

  • Took another stab at this with the @gateway and @proxy and still not working. I can see things scrolling by when my echo polls the camera but just times out.

    If someone has this DB2 working with gateway could you let me know your settings?

    Authentication : DIGEST
    Video Res : 2048*1536 [QXGA]
    H264, ACC
    Tried with both @proxy and @gateway both did not work.

  • @redcaesar

    Please see this thread.

    Some users have has success using certain special tags. I have the older Uniden DB1 version of this camera and I have not had any success.

    Thanks, Robert

  • @Monocle Thanks Robert that did the trick for me too!

Log in to reply