Foscam R2 with Lenovo Smart Tab [SOLVED]



  • This sounds like awesomeness. Looking forward to giving it a try. Thank you for turning this around so quickly. Much appreciated!



  • @skarragallagher

    I have not tested the Windows build yet, but here it is if you would like to try it out:

    Just add the following section to your monocle.properties file:

    #--------------------------------------
    # RTSP GATEWAY ACCESS KEY
    # use if exposing gateway to Internet
    #--------------------------------------
    rtsp.auth.key=WHATEVER_UNIQUE_TEXT_YOU_WANT
    

    You can provide some unique string for the rtsp.auth.key property.

    When attempting to ask Alexa to view a camera stream, you should see something like:

    -------------------------------------------------
    INITIALIZE RTSP STREAM:  Basement
    -------------------------------------------------
     - NAME          : Basement
     - CAMERA.MFG    : HikVision
     - CAMERA.MODEL  : DS-2CD2042WD-I
     - CAMERA.LABEL  : PRIMARY
     - RTSP.URL      : rtsp://10.1.2.115/Streaming/channels/101
     - STREAM.ID     : STREAM:000641fb-3f5a-4b35-aec3-af39baa2c882
     - SESSION.ID    : 3a73207a-dbe6-4f1a-b8bf-66f3212fcd4e
     - LAST.MODIFIED : Tue Feb 04 2020 15:30:14 GMT-0500 (Eastern Standard Time)
     - TAGS          : @tunnel
    -------------------------------------------------
    
    2020-02-05T21:37:56.034Z [INFO]  [10.1.2.90:37802 <r123rhufU>] RTSP CLIENT SOCKET CONNECTED
    
    -------------------------------------------------
    INBOUND RTSP CONNECTION FROM ALEXA:  [10.1.2.90:37802 <r123rhufU>]
    -------------------------------------------------
     - CLIENT.IP    : 10.1.2.90 ( <-- this should be your Alexa device)
     - CLIENT.PORT  : 37802
     - REQ.ID       : r123rhufU
     - REQ.PROTOCOL : RTSP/1.0
     - REQ.METHOD   : DESCRIBE
     - REQ.URL      : rtsp://_________.mproxy.io:443/STREAM:000641fb-3f5a-4b35-aec3-af39baa2c882?session=3a73207a-dbe6-4f1a-b8bf-66f3212fcd4e
     - STREAM.ID    : STREAM:000641fb-3f5a-4b35-aec3-af39baa2c882
     - SESSION.ID   : 3a73207a-dbe6-4f1a-b8bf-66f3212fcd4e
     - AUTH.HASH    : 82dcd3504d0234wefsdfsfs3gh36c78b32aff0df
    -------------------------------------------------
    
    2020-02-05T21:37:56.163Z [INFO]  [10.1.2.90:37802 <r123rhufU>] RTSP GATEWAY AUTH SUCCEEDED: ...
    2020-02-05T21:37:56.163Z [INFO]  [10.1.2.90:37802 <r123rhufU>] RTSP CLIENT ATTACHED TO STREAM: Basement (STREAM:000641fb-3f5a-4b35-aec3-af39baa2c882)
    
    

    Notice the “RTSP GATEWAY AUTH SUCCEEDED” message confirming a successful authentication.

    Thanks, Robert



  • I downloaded the 64 bit version and installed it. Seems to work just fine. No issues noted. Thank you for this!



  • One thing i noted with this tablet is that the streams will time out exactly after 10 minutes so it makes it rather annoying to keep an eye on my 4 year old during nap time…

    5a60ae4f-ba62-4064-8730-7c68c7ca1368-image.png

    Im wondering if there is any type of keep alive signal that can be sent so the server doesn’t disconnect the stream



  • @skarragallagher

    Can you post a monocle-gateway log for this camera stream request? I want to see if there is a session timeout declared in the RTSP communication from the camera. Also what make/model is this camera?

    Also, if you are using @tunnel try @proxy-tcp or @proxy and see if that makes any difference.

    Thanks, Robert



  • Sure, no problem. I will post logs shortly. I am using @tunnel. I haven’t tried the @proxy or @proxy-tcp. I will do some experimenting



  • I tried to post the logs but it said something like post flagged as spam



  • I tried all 3 tunnel/proxy/proxy-tcp and all of them disconnected at about 10m.



  • @skarragallagher

    We have had some recent trouble with spammers and have implemented additional spam protection. It must not like the content or length of the post?
    Did you try putting it inside <CODE> tags? Meaning, select with your cursor the log text and click the code formatting option above the text entry box. It should look like “</>”.

    Or you can do it manually by typing three back-tick characters (the keyboard button to the left of the number 1 key), like this …

    ```
    YOUR LOG TEXT
    ```

    Thanks, Robert



  • Sorry for the late reply, I did put it in code tags but will try again. I think its the server closing connection but not sure.

    So it still wont let me paste logs in… here is the onedrive link
    https://1drv.ms/t/s!AsWlCkfB-HIupWHo8u0KR2fy6uql


Log in to reply