@jacky2307 Lots of things can lead to buffering, but I would suggest trying the following: Make sure you Monocle Gateway is running on a system connected via Ethernet, not WiFI Try adding the @noaudio tag to your camera in the Monocle Web Portal. (alongside your existing @tunnel or @proxy tags) . Sometimes the audio channel causes Alexa to lag/buffer. Try the camera’s secondary/sub stream. Try a lower camera resolution by adjusting your camera’s own internal settings. Make sure the camera is connected to Ethernet instead of WiFi wherever possible. Thanks, Robert