Gateway api token not working [SOLVED]



  • Hi there I’ve set up a docker in bridge mode with the setting from the docker github I’ve managed to get them added to Alexa show 8” and show in my Alexa app on phone but I’m unable to view cameras on my Alexa. I’m reolink 420 and 410 5mp

    I’m Getting following error in gateway docker

    Monocle API Authentication Error; invalid or missing token.

    2020-01-31T20:27:14.424Z [ERROR] [Monocle Error] Unexpected server response: 401

    [ ‘[Monocle Error]’, ‘Unexpected server response: 401’ ]

    I’ve got the file linked to the docker and the api token copied from the portal saved inside it.



  • I’m having the same problem.



  • @efyouall one thing I’ve noticed with my cam urls is I need //h264 in the url for VLC but when I put this in the portal it changes it to single / not sure if that will hurt it or not.



  • Can’t get that far yet because the gateway won’t accept my token.



  • @efyouall I didn’t check the gateway at first and my cameras have came up on Alexa app but no picture but I’m guessing it to do with the api error.



  • And I thought it was just me being new to all this.



  • @XopherJ ha I know me too I’ve got it all setup just now having issues with the api but I’ve done everything it says saved the api token in the correct place etc.



  • Not sure if getting further or closer now receive these errors

    MONOCLE RUNTIME ENVIRONMENT
    -------------------------------------------------
    VERSION = 0.0.4
    
    OS/ARCH = linux/x64
    PROCESS = monocle-gateway (PID=1)
    TIMESTAMP = 2020-01-31T21:29:12.079Z
    
    -------------------------------------------------
    MONOCLE GATEWAY SERVICE (Version: 0.0.4)
    
    -------------------------------------------------
    [Monocle Starting]
    [Monocle Connecting]
    [Monocle Started]
    [RTSP Server Starting]
    [RTSP Server Listening] 192.168.1.100:554 (RTSP)
    [RTSP Server Listening] 192.168.1.100:443 (RTSP-TLS)
    [RTSP Proxy Started] (PID=14)
    [RTSP Server Listening] 192.168.1.100:8554 (PROXY)
    [RTSP Server Started]
    2020-01-31T21:29:12.106Z [ERROR] [PROXY SERVER ERROR] Error: listen EADDRNOTAVAIL 192.168.1.100:554
    
    [ '[PROXY SERVER ERROR]',
    
    { Error: listen EADDRNOTAVAIL 192.168.1.100:554
    
    at Object._errnoException (util.js:1031:13)
    at _exceptionWithHostPort (util.js:1052:20)
    at Server.setupListenHandle [as _listen2] (net.js:1350:19)
    at listenInCluster (net.js:1408:12)
    at doListen (net.js:1523:7)
    at _combinedTickCallback (internal/process/next_tick.js:141:11)
    at process._tickCallback (internal/process/next_tick.js:180:9)
    at Function.Module.runMain (pkg/prelude/bootstrap.js:1299:13)
    at startup (bootstrap_node.js:227:16)
    at bootstrap_node.js:649:3
    errno: 'EADDRNOTAVAIL',
    code: 'EADDRNOTAVAIL',
    syscall: 'listen',
    address: '192.168.1.100',
    port: 554 } ]
    2020-01-31T21:29:12.108Z [ERROR] [RTSP Server Error] listen EADDRNOTAVAIL 192.168.1.100:554
    
    [ '[RTSP Server Error]',
    
    'listen EADDRNOTAVAIL 192.168.1.100:554' ]
    2020-01-31T21:29:12.108Z [ERROR] [PROXY SERVER ERROR] Error: listen EADDRNOTAVAIL 192.168.1.100:443
    
    [ '[PROXY SERVER ERROR]',
    
    { Error: listen EADDRNOTAVAIL 192.168.1.100:443
    
    at Object._errnoException (util.js:1031:13)
    at _exceptionWithHostPort (util.js:1052:20)
    at Server.setupListenHandle [as _listen2] (net.js:1350:19)
    at listenInCluster (net.js:1408:12)
    at doListen (net.js:1523:7)
    at _combinedTickCallback (internal/process/next_tick.js:141:11)
    at process._tickCallback (internal/process/next_tick.js:180:9)
    at Function.Module.runMain (pkg/prelude/bootstrap.js:1299:13)
    at startup (bootstrap_node.js:227:16)
    at bootstrap_node.js:649:3
    errno: 'EADDRNOTAVAIL',
    code: 'EADDRNOTAVAIL',
    syscall: 'listen',
    address: '192.168.1.100',
    port: 443 } ]
    2020-01-31T21:29:12.108Z [ERROR] [RTSP Server Error] listen EADDRNOTAVAIL 192.168.1.100:443
    
    [ '[RTSP Server Error]',
    
    'listen EADDRNOTAVAIL 192.168.1.100:443' ]
    Monocle API Authentication Error; invalid or missing token.
    
    2020-01-31T21:29:12.562Z [ERROR] [Monocle Error] Unexpected server response: 401
    
    [ '[Monocle Error]', 'Unexpected server response: 401' ]
    


  • @Monocle any help here regarding the API errors and such I have here?



  • Still the same here, if I move or rename the token I the error “UNABLE TO FIND monocle.token” so it doesn’t like the token. I deleted and rebuilt a new token and it still doesn’t like it.



  • @efyouall yea same here I created a new and linked that still didn’t work.



  • @dathomas85

    Thank you for reporting this issue. Please see this topic for updated on this issue.
    https://forum.monoclecam.com/topic/606/attention-monocle-gateway-service-is-down



  • @dathomas85

    Are you able to get it working with your token now?

    Thanks, Robert



  • @Monocle I am able to get in now



  • Yes, it started now. Thank you



  • @efyouall @XopherJ

    Thanks for the confirmation!



  • @Monocle yes I now have the api token working but the issue now is that I can’t get my camera picture on the Alexa I just get the camera is not responding here is the log after it attempts to connect

    ******************************************************************
    * __ __ ___ _ _ ___ ___ _ ___ *
    * | \/ |/ _ \| \| |/ _ \ / __| | | __| *
    * | |\/| | (_) | .` | (_) | (__| |__| _| *
    * |_| |_|\___/|_|\_|\___/ \___|____|___| *
    * *
    ******************************************************************
    
    
    -------------------------------------------------
    MONOCLE RUNTIME ENVIRONMENT
    -------------------------------------------------
    VERSION = 0.0.4
    
    OS/ARCH = linux/x64
    PROCESS = monocle-gateway (PID=1)
    TIMESTAMP = 2020-02-01T02:01:28.941Z
    
    -------------------------------------------------
    MONOCLE GATEWAY SERVICE (Version: 0.0.4)
    
    -------------------------------------------------
    [Monocle Starting]
    [Monocle Connecting]
    [Monocle Started]
    [RTSP Server Starting]
    [RTSP Server Listening] 0.0.0.0:8555 (RTSP)
    [RTSP Server Listening] 0.0.0.0:443 (RTSP-TLS)
    [RTSP Proxy Started] (PID=14)
    [RTSP Server Listening] 0.0.0.0:8554 (PROXY)
    [RTSP Server Started]
    [Monocle Connected]
    [RTSP Server Registered]
    
    -------------------------------------------------
    MONOCLE RTSP SERVICE - INITIALIZED
    -------------------------------------------------
    FQDN = changedtohide.mproxy.io
    HOST = 192.168.1.100
    PORT = 443
    -------------------------------------------------
    
    -------------------------------------------------
    INITIALIZE RTSP STREAM: Driveway
    -------------------------------------------------
    - NAME : Driveway
    - LABEL : PRIMARY
    - URL : rtsp://192.168.1.100:554/h264Preview_02_sub
    - UUID : STREAM:0eb90e68-dcf1-4e0b-b72b-6a91875dab16
    - SESS : 067ced94-82d2-4671-9527-e058c08fce7c
    - MODIF : Sat Feb 01 2020 01:59:36 GMT+0000 (UTC)
    - TAGS : @tunnel
    -------------------------------------------------
    
    
    -------------------------------------------------
    INITIALIZE RTSP STREAM: Driveway
    -------------------------------------------------
    - NAME : Driveway
    - LABEL : PRIMARY
    - URL : rtsp://192.168.1.100:554/h264Preview_02_sub
    - UUID : STREAM:0eb90e68-dcf1-4e0b-b72b-6a91875dab16
    - SESS : 067ced94-82d2-4671-9527-e058c08fce7c
    - MODIF : Sat Feb 01 2020 01:59:36 GMT+0000 (UTC)
    - TAGS : @tunnel
    -------------------------------------------------
    
    
    -------------------------------------------------
    INITIALIZE RTSP STREAM: Driveway
    -------------------------------------------------
    - NAME : Driveway
    - LABEL : PRIMARY
    - URL : rtsp://192.168.1.100:554/h264Preview_02_sub
    - UUID : STREAM:0eb90e68-dcf1-4e0b-b72b-6a91875dab16
    - SESS : 2199f8b2-704a-4e7b-84b6-5f7bc08c04d1
    - MODIF : Sat Feb 01 2020 01:59:36 GMT+0000 (UTC)
    - TAGS : @tunnel
    -------------------------------------------------
    
    
    -------------------------------------------------
    INITIALIZE RTSP STREAM: Driveway
    -------------------------------------------------
    - NAME : Driveway
    - LABEL : PRIMARY
    - URL : rtsp://192.168.1.100:554/h264Preview_02_sub
    - UUID : STREAM:0eb90e68-dcf1-4e0b-b72b-6a91875dab16
    - SESS : 27db371b-b6ce-45fb-8a1b-329ad7111d9f
    - MODIF : Sat Feb 01 2020 01:59:36 GMT+0000 (UTC)
    - TAGS : @tunnel
    -------------------------------------------------
    

    If I go to the FQDN manually it takes me to the page I’d get if using my mobile inside my network for my cameras so I’m assuming that bits working fine just no picture yet my rtsp url work fine when in vlc.

    I’ve tried @tunnel, @proxy together @proxy alone and with @noaudio as well as @tunel with @noaudio all to no luck.



  • @dathomas85

    I followed up on your other thread:
    https://forum.monoclecam.com/topic/607/alexa-camera-not-responding

    Thanks, Robert


Log in to reply