Monocle Gateway and Unifi Protect camera with Alexa Show 5



  • Hi there have successfully installed the Monocle Gateway Service application on Windows 10, installed the windows service, added the camera rtsp feeds from my three cameras, tested in VLC for correct codecs and that they stream correctly including the audio, checked for DNS rebinding by pinging the proxy.io address, which comes back with the IP of my PC, set all the tag options and permutations for each camera, checked camera feed history for Alexa request calls, and all seems well BUT…when I ask Alexa to show the relevant camera I just get, after about 15-20 seconds…"Hmmm the camera named “XXX” is not responding. Any ideas. Echo Show 5 and cameras are all on the same network. Cameras are connected to a Ubiquiti cloud key controller again all on the same network. Im running on a BT Smart Hub6 dual band router with no port forwarding but this should be irrelevant when accessing RTSP streams from within my own LAN right? Also UBiquiti uses port 443 within the inbuilt Unifi Protect software that is installed on the controller/NVR



  • Hi. What camera models and which streams/resolutions are you using?



  • @GreggC I am using 2 x UVC G3 Pros and 1 x UVCG3 Flex, all RTSP streaming at 1920 x 1080.



  • @topolino65 I haven’t tested the G3 Pro with Monocle, but can confirm that the Flex works.

    Are you trying to stream directly from the cameras or the CloudKey/NVR? Since your cameras are managed by Protect, I think you must stream from the NVR because the RTSP feeds directly from the cameras gets disabled once they’re adopted to Protect.





  • @GreggC Thanks Gregg. I’m streaming from the cameras using the RTSP streams enabled within the UniFi protect software on the NVR I have the ability to view the RTSP streams from all the cameras in the Windows VLC player and have checked the codecs are compatible, also checked for DNS rebinding and all good. Also I can see from the cameras feeds page on the Monocle portal when the camera access was requested by Alexa, it just doesn’t show up on the device and I get the Alexa message “Hmm…the camera is not responding”



  • @topolino65 I can’t think of anything else off the top of my head other than in the Alexa app to disable and re-enable the Monocle skill and let it rediscover the cameras. I have had to do that after making various changes in the environment.



  • OK I will give it a try, thanks.



  • GreggC no luck with that however when I look at each camera in the Alexa app it says it is’Connected Via’ “Camera name” as opposed to the “Monocle Gateway” service. Is this normal?



  • Here is the last camera feed request for the Flex camera received from Alexa on the portal

    [
    {
    “timestamp”: “2020-02-19T15:00:48.143Z”,
    “request”: “InitializeCameraStreams”,
    “response”: [
    {
    “uri”: “rtsp://192.168.1.30:7447/iXsCRn9LPMJlPCj4”,
    “proxy”: “rtsp://7c1f4f75-bcba-4db9-b6a7-9764bf3be715.mproxy.io:443/STREAM:b84218f9-bf45-4cdc-b8dc-c72ce1241415?session=5c19cbdc-4764-44e3-93b0-76ea89ecff70”,
    “idleTimeoutSeconds”: “10”,
    “resolution”: {
    “width”: “1920”,
    “height”: “1080”
    },
    “authorizationType”: “NONE”,
    “videoCodec”: “H264”,
    “audioCodec”: “AAC”,
    “protocol”: “RTSP”
    }
    ]
    },



  • Hi, I have about 6 Unifi cameras up and running right now and have the monocle gateway running. My cameras are showing as requested on the FireTV 4K and an Alexa Show 5.

    I didnt see you say (if you did, I missed it), that you did the camera discovery via the Alexa app. ?

    For the monocle setup, you dont need authentication. The RTSP link the Protect program generates has a key in the string that is the authentication.

    Need the tag… @tunnel

    Also, I’m running a lower resolution, haven’t tried it at a higher. During the research of setting up monocle it was recommended in a few cases to just go to the lower res, more responsive.
    Here’s the dashboard settings from one of my unifi cameras
    monocle-Capture.JPG



  • @topolino65 said in Monocle Gateway and Unifi Protect camera with Alexa Show 5:

    Alexa app it says it is’Connected Via’ “Camera name”

    So., seems you did the discover the cameras…
    fyi, my alexa says the same thing for each camera.: Connected Via’ “Camera name”

    and see "authorizationType”: “NONE”, in your posting of the feed request.

    Last would seem… Did you do the tunnel tag?

    I’m running several Flexes, Dome, G3 pro, G3 Bullet, all working.



  • +1 on what bk has said, though I couldn’t open the JPG.

    I can check my Monocle setting later if still needed.

    To confirm, I have run with 1920 x 1080 (and higher) no problem. I have tested will all 3 UniFi streams (high, medium, low), and no matter the resolution of a particular stream on a particular camera model I’ve had success.

    Regarding RTSP authentication, I once thought I had it up with Monocle before I realized it doesn’t even get used. No matter, it doesn’t get in the way.



  • @GreggC said in Monocle Gateway and Unifi Protect camera with Alexa Show 5:

    though I couldn’t open the JPG.

    I broke the link, let me fix it…
    here…
    monocle-Capture.JPG

    I don’t know if the concerns are with the Show 5 regarding the stream’s resolution, or just responsiveness. I haven’t dickered with it… just left it as shown. On the FireTV and show5, is looks great as is and comes up quick when requested. Blows away Ring and their streaming delays . Seems a 50/50 change the Ring stream will ever load. Unifi needs its own doorbell cam.



  • my two last clean ups were the Authentication and Tag… I had authentication in there and it didn’t work. since I had the six cams up, just took pot shots / different configs for each cam at what would and wouldn’t work, since it didn’t when first tried…but all streams worked with VLC .
    I found a post on the Unifi forum of why the Authentication wasn’t needed, and found on here about the Tags… and @tunnel needed.



  • @bk thanks for your reply. Yes as you can see I get the responses through from Alexa when I check on the portal and authentication is set to none, tag is set to @tunnel and resolution is set to 1920 x 1080. Still no luck. Monocle service is running and I have added the API token to the correct folder in Windows. I will try adding the three cameras again to Alexa via the app each at low med and high res (so 3 x each camera) and see which if any work. BTW I tried the A@proxy with and without @noaudio tags and still no joy



  • @topolino65 ,

    Have you tried killing the service… and just run from the elevated CMD session?

    I have not yet installed Monocle as a service, still running off of some batch files (so less typing) in the cmd / admin level session… with the 6 cameras running, I should sit down and install the service.

    I assume when you say you have API token on the “correct windows folder”… you have it in the same folder as the monocle-gateway executable ?

    My monocle folder is right under the root for my c drive.

    Sorry of some of this is basic… just trying to stab at things, since it seems it should be working.
    I feel your pain…



  • @bk said in Monocle Gateway and Unifi Protect camera with Alexa Show 5:

    Have you tried killing the service… and just run from the elevated CMD session?

    Thanks @bk.

    Do you mean killing the windows service from running and running Monocle from the command prompt? If so whats the syntax from the 😄 prompt before I try calling for a feed from Alexa?



  • @topolino65 said in Monocle Gateway and Unifi Protect camera with Alexa Show 5:

    Do you mean killing the windows service from running and running Monocle from the command prompt? If so whats the syntax from the prompt before I try calling for a feed from Alexa?

    Yes…
    https://monoclecam.com/monocle-gateway/install/windows
    midway down…
    The following commands can be executed in a command window to install, uninstall, start, stop and restart the Monocle Gateway windows service. You must run the command window as an administrator to control windows services.

    Install the Windows service: monocle-gateway.exe --install
    
    Start the Windows service: monocle-gateway.exe --start
    
    Stop the Windows service: monocle-gateway.exe --stop
    
    Restart the Windows service: monocle-gateway.exe --restart
    Uninstall the Windows service: monocle-gateway.exe --uninstall
    

    So kill that service.
    run cmd as administrator… go to your monocle directory… and the token needs to be in that directory as well, then execute monocle-gateway.exe



  • FYI, seems to help if after you make changes to the monocle dash board, you kill the monocle gateway and restart it. Then delete and re-discover the cameras. I just did a tweak to one of the g3 pro’s , and it didn’t respond, those three steps other and it was up and running again.
    -change dashboard
    -kill , restart gateway
    -kill camera in alexa
    -re-discover camera in alexa


Log in to reply