ANPVIS IPC-B850W-D - Hikvision Compatible - Gateway not connecting to stream



  • Camera:
    http://anpvizsecurity.com/https-wwwamazoncom-dp-b07n3y4hs6-p00466p1.html

    Can you please help. I have the gateway running on server 2012.
    I have tested the stream in VLC and verified the codec etc.
    I have checked the external mproxy DNS entry is mapped to my servers IP
    When i try and show the camera on amazon show 8 it can says “The camera isnt responding”
    it never brings up the lines as expected in the guide…

    “2018-06-08T18:48:54.971Z [INFO] [10.1.2.217:40172 <BJkj18ulm>] RTSP CLIENT SOCKET CONNECTED
    2018-06-08T18:48:55.103Z [INFO] [10.1.2.217:40172 <BJkj18ulm>] RTSP CLIENT ATTACHED TO STREAM: Kitchen (STREAM:99d01a23-c6sd-46-bb11-v1d9edda4523)”

    I only see the parts above that… Here is my output

    -------------------------------------------------
    INITIALIZE RTSP STREAM:  Drive
    -------------------------------------------------
     - NAME  : Drive
     - LABEL : PRIMARY
     - URL   : rtsp://192.168.1.224:554/Streaming/Channels/101
     - UUID  : STREAM:474c5c57-22a1-45d4-9234-2f60dff67923
     - SESS  : 1377a26a-7304-4545-a3c8-0881cfc621ea
     - MODIF : Mon Mar 23 2020 11:47:50 GMT+0000 (GMT Standard Time)
     - TAGS  : @fake-smtp,@noaudio,@proxy-tcp
    -------------------------------------------------
    

    I have tried all the available tags and several rstp streams. I have tried with and without authentication.
    I have tested with different resolutions in the camera and monocle.

    Here is the monocle debug

    [
      {
        "timestamp": "2020-03-23T12:08:04.683Z",
        "request": "InitializeCameraStreams",
        "response": [
          {
            "uri": "rtsp://%USER%:%PWD%@192.168.1.224/Streaming/Channels/101",
            "proxy": "rtsp://c7b89e31-cbf3-4ff5-acb6-1edc4a506a06.mproxy.io:443/STREAM:474c5c57-22a1-45d4-9234-2f60dff67923?session=1377a26a-7304-4545-a3c8-0881cfc621ea",
            "resolution": {
              "width": "1280",
              "height": "738"
            },
            "authorizationType": "DIGEST",
            "videoCodec": "H264",
            "audioCodec": "NONE",
            "protocol": "RTSP"
          }
        ]
      }
    

    Can you please help?



  • also… should i be able to ping “c7b89e31-cbf3-4ff5-acb6-1edc4a506a06.mproxy.io” successfully?


Log in to reply