Cannot view channel zero using RTSP



  • Hi,

    I think the Monocle site / facility is great. I can view my four IP cameras on all Amazon Alexa devices around my home. Brilliant.

    I am now trying to view the channel zero feed from my Hikvision NVR Model DS-7608NI-E2 / 8P/A. As you might know, some NVR’s have a channel-zero feed that shows multiple camera images on the same image.

    I have tested the RTSP URL below in VLC Player and I can see my channel-zero feed no problem. The IP address of my actual NVR is .57. The link below works in VLC player as a Network Stream, but it doesnt work when I create a new camera in Monocle.

    rtsp://192.168.1.57:554/Streaming/Channels/001/ - This doesn’t work in Monocle but does work in VLC player

    In the example below, .101 is the IP address of a Hikvision IP cam which is on the same NVR (I only have one NVR). This works fine in Monocle and I can see the camera on my Alexa’s.
    rtsp://192.168.1.101:554/Streaming/Channels/101/ - This DOES work in Monocle and does work in VLC player

    When I try and view the channel zero on Alexa she says “Hmm - the camera isnt responding”.

    I have the correct password in the Monocle camera settings. I’ve tried everything. I have added the new camera to my Alexa. It appears in the camera devices on the Alexa App. I added the channel zero to Alexa exactly the same as I added the other 4 cams which all work fine with Alexa.

    I understand the channel zero on my NVR isn’t actually a camera, but it does have a valid RTSP address and the channel zero RTSP feed does work in VLC player.

    Is this something Monocle support are aware of? Is there any reason why the RTSP address for my channel zero doesnt work with Monocle? (but does with VLC player?).

    Like I say, I think the Monocle website and service is great. I’m impressed I can view my four IP cams on my Alexa’s. It would be a bonus if I could view my channel zero feed too.



  • Hi,

    I still havent managed to get my Hikvision channel zero feed to work on my Alexa shows.

    For info, all 3 URL’s below show my channel zero with VLC Player but not on Alexa.

    My main camera feeds still work fine on Alexa Shows .e.g rtsp://192.168.1.101:554/Streaming/Channels/101/ works fine (.101 is actual camera).

    The resolution of my channel zero is 704 x 576 so not very high resolution (my Alexa shows should be able to hande this resolution easily).

    These work on VLC Player but not on Alexa.
    rtsp://192.168.1.57:554/Streaming/Channels/001/
    rtsp://192.168.1.57:554/Streaming/Channels/001?videocodec=jpeg&Transport=HTTP
    rtsp://192.168.1.57:554/Streaming/Channels/001?videocodec=jpeg&Transport=multicast

    I tried adding some additional parameters to the rtsp URL to see if that made any difference (it didn’t).

    Would still appreciate some tips please.



  • Have you read the documentation? Take a look at tags. My Foscam, for example, requires @proxy. Others need @tunnel. I believe there are other tags too.



  • I know this is a free service, but I’m a little disappointed no one from Monocle has responded to my post that I made two weeks ago. There was an option to make a post that I thought technical support would look at (and I think I posted it under the correct category?).

    I still think the service is excellent, but it would be great to know why I cannot view the channel zero feed from my hikvision NVR on my Alexa. My channel zero feed works fine when I view it on VLC player.

    Monocle allows me to view the feeds from my Hikvision IP cameras and from two Chinese pinhole cameras no problem.

    I have tried using parameters in the Monocle settings as someone suggested but that has not made any difference.

    I understand the channel zero feed is not a true camera feed and is not actually a channel on the nvr, but like I say, I can view it no problem using VLC so it would be great to view my channel zero feed using the Monocle app.

    Please see original post above for more information.



  • @Esso

    I apologize for the delay … I have been away from this project for a few weeks due to STAY AT HOME orders and managing kids at home and other work during this COVID crisis.

    I have seen the zero channel work on some (but not all) NVRs. It could be related to the stream resolution? First, which Alexa device are you using to try and see the zero channel stream? Some devices like the Echo Show 5 and 8 are limited to 1080P streams. If you can view the zero channel stream in VLC … can you verify what resolution this stream is producing?

    Thanks, Robert



  • Thank you kindly for your reply. I know the coronavirus is causing problems for many workers but I thought you might be working remotely.

    If you look at my first post I do mention the resolution of the channel zero feed. I did a lot of research before making my posts and I know a few people have mentioned the resolution.

    The resolution of my channel zero is 704 x 576 so not very high. My Alexa show should be able to hande this resolution.

    Like I say, VLC shows the feed from my channel zero perfectly. VLC shows the resolution as 704 x 576. I have tried using different parameters at the bottom of the configuration screen but nothing I tried worked (could you give me any additional tips?).

    The reason it would be so useful to view the channel zero is because I would see all all four cameras at once on my Alexa show. The 8 inch screen on my Alexa show would make it a great console to see all cameras at once.

    Suggestion: Could you consider implementing a carousel (auto scroll) feature that would show each of the enabled camera feeds for a pre determined amount of time eg 4s? I notice there is a delay whenever I access a camera so I am not sure how how effective this would be. It’s just a way of using the Alexa show to be able to monitor all cameras without having to keep changing them with a voice command.

    This might work similar to the command to play music on several different Alexa devices. To do this I can say “Alexa… play my playlist Madonna downstairs”. The addition of the downstairs command means I will hear music on all of my devices downstairs.

    Something similar such as “Alexa, show garden and rotate” or “Alexa… show all cameras”.

    This would be an excellent feature, especially if there was a way to pre buffer (pre load) the image so when the next camera feed was shown there was no visual delay.

    I am still very impressed with with your service. Like many users, I am always looking for ways to maximize the usefulness of such a great Alexa skill.

    Thank you for your time.



  • I forgot to mention which Alexa Echo Shows I have.

    2 x Echo Show (2nd Gen) With 10 Inch Full HD Display.

    2 x older style Echo show 7 inch.

    2 x Echo Spots with 2.5 inch screens. I havent used these smaller devices to view any camera feeds but I will experiment with them later today.

    All my Echo Shows display my camera feeds perfectly.

    It was easy to get my expensive hikvision cameras to work with Monocle but the pinhole Chinese cameras were a little more challenging. Once I got the parameters correct my Echo Shows also displayed these images clearly using the Monocle skill.



  • @Esso

    I have just tried the Monocle skill on my Echo Spots 2.5 inch screen. My camera feeds work fine. The image is still very clear even on a 2.5 inch screen.

    I also tried my channel zero feed on the Echo spot but got the same message I get on all of my other devices. Alexa can’t display the image.

    Robert, any advice or feedback you could give me regarding my last few posts above would be really appreciated.



  • @Esso said in Cannot view channel zero using RTSP:

    Thank you kindly for your reply. I know the coronavirus is causing problems for many workers but I thought you might be working remotely.

    I am, however – only part time at the moment and this is not the only active project.

    If you look at my first post I do mention the resolution of the channel zero feed. I did a lot of research before making my posts and I know a few people have mentioned the resolution.
    The resolution of my channel zero is 704 x 576 so not very high. My Alexa show should be able to hande this resolution.

    Sorry, I missed that – you are correct - that low of a resolution would work fine on all Alexa enabled devices.

    Like I say, VLC shows the feed from my channel zero perfectly. VLC shows the resolution as 704 x 576. I have tried using different parameters at the bottom of the configuration screen but nothing I tried worked (could you give me any additional tips?).

    I think we are going to need to get captures of the Monocle Gateway log file and inspect that first to see where Alexa seems to be failing on the stream. One shot in the dark thing you can try is to use the tag @fake-fmtp on this camera stream in the Monocle web UI.

    The reason it would be so useful to view the channel zero is because I would see all all four cameras at once on my Alexa show. The 8 inch screen on my Alexa show would make it a great console to see all cameras at once.

    I fully understand.

    Suggestion: Could you consider implementing a carousel (auto scroll) feature that would show each of the enabled camera feeds for a pre determined amount of time eg 4s? I notice there is a delay whenever I access a camera so I am not sure how how effective this would be. It’s just a way of using the Alexa show to be able to monitor all cameras without having to keep changing them with a voice command.

    This might work similar to the command to play music on several different Alexa devices. To do this I can say “Alexa… play my playlist Madonna downstairs”. The addition of the downstairs command means I will hear music on all of my devices downstairs.

    Something similar such as “Alexa, show garden and rotate” or “Alexa… show all cameras”.

    This would be an excellent feature, especially if there was a way to pre buffer (pre load) the image so when the next camera feed was shown there was no visual delay.

    Please see this thread:
    https://forum.monoclecam.com/topic/53/split-quad-round-robin-views

    It’s not possible with the support and APIs currently offered by Amazon/Alexa. It might be possible if we implement a more sophisticated version of Monocle Gateway where the gateway performs the advanced behavior and produces a single stream for the Alexa device to consume. This is something we hope to experiment with soon to see what might be possible. It may require running the gateway on more powerful hardware and may cause additional latency – we will have to see.

    I am still very impressed with with your service. Like many users, I am always looking for ways to maximize the usefulness of such a great Alexa skill.

    Thank You! I hope to get back to work on this project to add some new features soon.



  • @Esso said in Cannot view channel zero using RTSP:

    These work on VLC Player but not on Alexa.
    rtsp://192.168.1.57:554/Streaming/Channels/001/
    rtsp://192.168.1.57:554/Streaming/Channels/001?videocodec=jpeg&Transport=HTTP
    rtsp://192.168.1.57:554/Streaming/Channels/001?videocodec=jpeg&Transport=multicast

    The ?videocodec=jpeg will not work. Alexa does not support MJPEG or any other type of codec besides H.264. Can you use VLC and confirm the “zero channel” stream is in fact a H.264 stream? Also what if any audio stream are included. See: https://monoclecam.com/troubleshoot/validate-codecs

    Thanks, Robert



  • Hi Robert,

    Thanks for your replies.

    1. The following rtsp address works on VLC and shows the 4 cameras for my Channel Zero feed. .57 is the IP of my NVR on my LAN.
      rtsp://192.168.1.57:554/Streaming/Channels/001/

    2. According to VLC my Channel Zero feed is H264. VLC codec info tab shows:-
      Stream 0
      Type: Video
      Codec: H264 - MPEG-4 AVC (part 10) (h264)
      Resolution: 704x578
      Decoded format: Planar 4:2:0 YUV

    3. I tried to use the @fake-fmtp parameter as a Monocle tag in the settings but Alexa says “Hmm, the camera isnt respodning”.

    For additional info, I know Monocle on my Echo show can access my camera feeds in two different ways:-

    1. By accessing each of my cameras directly on my LAN.
    2. By connecting to my Hikvision NVR then showing the camera feed via that IP (.57).

    For example, the local IP for my front camera is:-
    rtsp://192.168.1.101:554/Streaming/Channels/101/
    101 is the camera IP address and /101 is ch1 feed 1 (its a coincidence they are both “101”.

    The IP for my NVR is .57 and my front camera os No 1 (101)
    rtsp://192.168.1.57:554/Streaming/Channels/101/

    Both of these addresses work in VLC and both work in Monocle.

    So I know Monocle can access all 4 cams either directly or via my NVR. This is why I think it should be possible to view my channel zero feed by connecting to my NVR on rtsp://192.168.1**.57**:554/Streaming/Channels/001/
    The 001 being channel zero feed 1 (primary feed).

    Robert, you mentioned getting captures of the Monocle Gateway log file and inspecting that to see where Alexa seems to be failing on the stream.

    How can I provide you with the Monocle Gateway log file?


Log in to reply