Fios G3100 router and mproxy.io issues



  • We just got “upgraded” to the Fios 3100 router and our IP cameras are not getting pushed to our alexa devices. I’ve kind of narrowed it down to probably the mproxy.io blocking. Does anyone use the 3100 router and have things working? Forwarding ports maybe, DDNS exemptions?



  • @x24 said in Fios G3100 router and mproxy.io issues:

    Fios 3100

    This is most likely a DNS REBINDING issue (https://monoclecam.com/monocle-gateway/troubleshooting/dns-rebinding) where the Alexa device is not able to resolve the DNS record for your custom *.mproxy.io address assigned to your Monocle Gateway. Some routers will prevent public DNS records from resolving to local private IP addresses inside your network. However, Alexa devices will only connect to real DNS hostnames and not directly to IP addresses. So as you can see … this is a catch 22 situation. We have to use a public host record for Alexa but some routers will block DNS resolution for hostnames that resolve to local/internal addresses. We want to keep all your audio/video data private and only streaming on your internal/private lan and not across the Internet.

    So the first step would be to try and see if there are any options in your router to create an exception for the *.mproxy.io domain. Specifically look up the term DNS REBIND along with your router model.

    If you router does not proivide any means to allow *.mproxy.io resolution, then does it allow you to create custom host records where you can just enter your specific xxxxxxxxxxxx.mproxy.io address and manually assign it to the local IP address of your Monocle Gateway instance.

    Thanks, Robert



  • Sorry for such a late reply. I will have to figure out how to go about doing that on the router as I’ve only started to familiarize myself with it’s new interface. I believe I was able to get the xxxx.mproxy.io address you mentioned as it was listed on the “possible DNS-rebind attack detected” entry in the system log.
    I found “Network Objects” under the Advanced section of the router, where I can add it as a host name and entered the xxxx.mproxy.io value. But it doesn’t let me tie it to an IP address, so maybe this is not the right method.
    Router interfaces may be calling things differently, I guess I just need to find the correct term.


Log in to reply