Alexa Skill Stopped Working?



  • 4x Amcrest cameras connected to QNAP. Multiple Echo Shows (original and newer 8inch)

    Issue: If I ask Alexa “Alexa show front door” she responds with “sorry I don’t know that” as if the skill isn’t enabled. When I’ve had camera/network issues in the past Alexa will say “hmm I can’t connect to [camera]” or “[camera] isn’t responding”

    Monocle skill is enabled (tried disabling/re-enabling).
    Devices all worked fine two days ago.
    I can see RSTP streams in VLC/QVR pro client/apps.
    If I use the touch interface on the newer Echo Show, I can select my cameras from the smart devices and they will display correctly on the Echo Show.

    The only thing I’ve done over the past 48 hours is physically move my NAS (QNAP) from location to another within the house. All cameras work, so I’m not sure what’s going on. It seems like an Alexa skill issue. Anyone have similar issues/suggestions?



  • I get the exact same message which is different from previous Alexa responses. I didn’t move or reset anything. I didn’t try the touch interface.



  • Echo Show 2nd Generation
    Amcrest IP4M-1054E Cameras
    Amcrest IP4M-1028E Camera
    Fire TV Cube
    Monocle Gateway

    I am also getting this message today on both my Echo 2nd Gen and Fire TV Cube.

    I disabled the Monocle app and re-enabled. That did not fix the problem.

    I also restarted the Monocle Gateway. No change.

    Cameras are all working. All display on Blue Iris on my PC and on the IP Cam Viewer App on the Fire TV Cube



  • Exact same issue but except different Camera type. Ran same tests and same results. I’ve made no changes and everything worked great up to a couple of days ago.



  • I am having the exact same problem, started 2 or 3 days ago if memory serves.

    Interestingly, it will work exactly ONE TIME if I change the name of the device inside the Alexa App. But then will not work again afterwards.

    I opened a case with Alexa support, and that was an exercise in futility to put it nicely…



  • Interestingly, I noticed that the skill activation changed to be ‘Show THE xxxxx’ versus ‘Show Me xxxx’ or just ‘Show xxxx’. This happened 3 days ago. If you don’t use THE, Alexa burps



  • @samern Amazing. That worked.

    Thank you.



  • I was trouble shooting this yesterday and found I had to add “camera” to the end, works with or without “the”…
    "…Show XXXX Camera "



  • Confirmed adding “THE” and “CAMERA” solves the problem. What the heck is the point of “THE” though, that makes it hard to use certain names… example: “Show me CHILDNAME’s room camera” becomes “Show me the CHILDNAME’s room camera”.



  • I just tried your suggestion and it works! I’m not sure how you figured that out but it’s more intuitive your way. I would think that everyone should be having this same issue. Thanks for letting me know !!!



  • I found for what ever it’s worth… the Echo shows didnt care if it was “the” or “camera” or both, but needed one of them or both of them, either and both Syntax worked…

    The FireTV 4K stick , seemed adding “camera” at the end was the constant fix… “the” , I can’t say it always responded, maybe it’s my NY accent… 😉 , but always responded with “camera” at the end as the fix.



  • @exr90 Just dont need “the” when always using “camera” at the end… so the “camera” syntax makes more sense in what your commanding Alex to show… not a movie, not a TV show, not a podcast, but a “camera”. I was sort of shocked at the start “camera” wasn’t needed as a qualifier. Some help pages show camera before or after the name of the camera, I haven’t tried that… as in “show me camera kids room” of “show me kids room camera” … the help article from amazon suggested both would work… I havent tried it. but having “camera” at the end as a qualifier makes sense IMHO.



  • It always responds to my North Idaho “Red Neck” accent! Go figure?


Log in to reply