Error listen port 443



  • Hi I’ve been struggling for a few days with the same error which I’m sure is preventing me from seeing my camera on an echo show 5

    the error is as below. I’ve read quite a lot of posts but still unsure how to fix this problem

    any help is much aprecceated

    
     ******************************************************************
     *             __  __  ___  _  _  ___   ___ _    ___              *
     *            |  \/  |/ _ \| \| |/ _ \ / __| |  | __|             *
     *            | |\/| | (_) | .` | (_) | (__| |__| _|              *
     *            |_|  |_|\___/|_|\_|\___/ \___|____|___|             *
     *                                                                *
     ******************************************************************
    
    
    -------------------------------------------------
    MONOCLE RUNTIME ENVIRONMENT
    -------------------------------------------------
    VERSION   = 0.0.4
    OS/ARCH   = win32\x64
    PROCESS   = monocle-gateway (PID=12052)
    TIMESTAMP = 2020-12-09T16:32:34.302Z
    
    -------------------------------------------------
    MONOCLE GATEWAY SERVICE         (Version: 0.0.4)
    -------------------------------------------------
    [Monocle Starting]
    [Monocle Connecting]
    [Monocle Started]
    [RTSP Server Starting]
    [RTSP Server Listening] 0.0.0.0:8555 (RTSP)
    [RTSP Server Listening] 0.0.0.0:443 (RTSP-TLS)
    [RTSP Proxy Started] (PID=1480)
    [RTSP Server Listening] 0.0.0.0:8554 (PROXY)
    [RTSP Server Started]
    2020-12-09T16:32:34.413Z [ERROR] [PROXY SERVER ERROR] Error: listen EACCES 0.0.0.0:443
    [ '[PROXY SERVER ERROR]',
      { Error: listen EACCES 0.0.0.0:443
        at Object._errnoException (util.js:1031:13)
        at _exceptionWithHostPort (util.js:1052:20)
        at Server.setupListenHandle [as _listen2] (net.js:1350:19)
        at listenInCluster (net.js:1408:12)
        at doListen (net.js:1523:7)
        at _combinedTickCallback (internal/process/next_tick.js:141:11)
        at process._tickCallback (internal/process/next_tick.js:180:9)
        at Function.Module.runMain (pkg/prelude/bootstrap.js:1299:13)
        at startup (bootstrap_node.js:227:16)
        at bootstrap_node.js:649:3
        errno: 'EACCES',
        code: 'EACCES',
        syscall: 'listen',
        address: '0.0.0.0',
        port: 443 } ]
    2020-12-09T16:32:34.421Z [ERROR] [RTSP Server Error] listen EACCES 0.0.0.0:443
    [ '[RTSP Server Error]', 'listen EACCES 0.0.0.0:443' ]
    [Monocle Connected]
    [RTSP Server Registered]
    
    -------------------------------------------------
    MONOCLE RTSP SERVICE - INITIALIZED
    -------------------------------------------------
    FQDN = 8102dc79-5d44-4a2e-b393-845cbbe4ddf0.mproxy.io
    HOST = 192.168.1.235
    PORT = 443
    -------------------------------------------------
    
    -------------------------------------------------
    INITIALIZE RTSP STREAM:  Garden
    -------------------------------------------------
     - NAME  : Garden
     - LABEL : PRIMARY
     - URL   : rtsp://192.168.1.18:554/1/h264major
     - UUID  : STREAM:f9339dd4-f8ce-4dec-9846-77f29653cf61
     - SESS  : 7a6c531a-6212-4b19-bb33-2cb86bcd17a4
     - MODIF : Tue Dec 08 2020 20:39:58 GMT+0000 (GMT Standard Time)
     - TAGS  : @noaudio,@tunnel
    -------------------------------------------------
    
    
    -------------------------------------------------
    INITIALIZE RTSP STREAM:  Garden
    -------------------------------------------------
     - NAME  : Garden
     - LABEL : PRIMARY
     - URL   : rtsp://192.168.1.18:554/1/h264major
     - UUID  : STREAM:f9339dd4-f8ce-4dec-9846-77f29653cf61
     - SESS  : db4bcd6c-0984-4c7e-9ffe-6a0245e670f4
     - MODIF : Tue Dec 08 2020 20:39:58 GMT+0000 (GMT Standard Time)
     - TAGS  : @noaudio,@tunnel
    -------------------------------------------------
    
    
    -------------------------------------------------
    INITIALIZE RTSP STREAM:  Garden
    -------------------------------------------------
     - NAME  : Garden
     - LABEL : PRIMARY
     - URL   : rtsp://192.168.1.18:554/1/h264major
     - UUID  : STREAM:f9339dd4-f8ce-4dec-9846-77f29653cf61
     - SESS  : acc6bbc3-56f3-4431-9c50-3ee3f621646d
     - MODIF : Tue Dec 08 2020 20:39:58 GMT+0000 (GMT Standard Time)
     - TAGS  : @noaudio,@tunnel
    -------------------------------------------------
    
    


  • I should add I’m on windows 10, I can ping the FQDN perfectly fine so can verify the port is correct



  • Have you opened the firewall/router port?



  • @billyc66 said in Error listen port 443:

    I should add I’m on windows 10, I can ping the FQDN perfectly fine so can verify the port is correct

    The ping test does not verify port 443 only the DNS resolution of the address. (Technically speaking, its using IGMP to perform the ping.)

    I suspect either …
    (1) something else on the computer is already using port 443.
    (2) Windows firewall is blocking access to port 443, which you can create an exception for.
    (3) you have another instance of Monocle Gateway running in the background (perhaps as a Windows service?)

    #1 or #2 is most likely the problem 🙂



  • @johns2k I tried but it had no effect, maybe I did it wrong the router is
    zyxel VMG3925-B10B

    thank you for replying



  • @Monocle i can see under

    outbound rules BranchCache Hosted Cache Server(HTTP-Out) uses port 80, 443

    and inbound rules
    Secure Socket Tunneling Protocol (SSTP-In) port 443
    World Wide Web Services (HTTPS Traffic-In) port 443
    @netlogon.dll,-1003 port 443
    BranchCache Hosted Cache Server (HTTP-In) port 443

    i set a new rule inbound and outbound to 443 for monocle (not sure if this is correct)

    thank you for responding



  • i just tried to forward port 443 on the router to 192.168.1.235 and i got the message

    Port 443 is being used by the VMG3925-B10B, please change your Start port and End port to avoid this conflict.



  • i can set the https port on the router to 444 under the remote manegement, then that allows me to port forward to 443, i assume im supposed to port forward to 443 for ip 192.168.1.235 i dont know what the the wan interface should be set at options are
    ethwan
    adsl
    vdsl
    wwan
    protocol i set as tcp/udp

    after doing that, i tried disabling the windows firewalls but still got the same proxy error, bot sure if i needed to restart windows

    again thank you for any help



  • ok so I opened 443 on the router tcp/udp, then checked with online port checker - shows the port open
    next, I run cmd (admin mode) and run NET stop HTTP
    and it worked, I cant check the echo show until tomorrow, but I will report back

    would there be any issues like security or anything not working correctly in windows doint this



  • ok so i got it to show the camera for a brief second on the echo show, so now just need to figure why it only shows for a couple of seconds

    i cant updload log it gets classed as spam and wont post



  • Can your screenshot the log?



  • @johns2k actually after posting the last reply i run the gateway again and it’s running fine now except for around 10 seconds, so I’m gonna try and figure how I can lower that



  • @billyc66 sorry that should say 10 seconds lag in the last post


Log in to reply