Dahua IPC-HFW2100 : i can't make it work



  • has anyone suggestions to make this camera work?

    i tried with “rtsp://IP:PORT//live” and with “rtsp://IP:PORT/live/cam/realmonitor?channel=1&subtype=1” ( which both works with vlc )



  • @andyf

    Which Alexa device are you using?

    Also make sure the camera is configured for AAC audio encoding in the camera’s own web config (or disabled).

    This RTSP URL looks correct for Dahua cameras.

    rtsp://IP:PORT/live/cam/realmonitor?channel=1&subtype=1
    


  • @Monocle said in Dahua IPC-HFW2100 : i can't make it work:

    @andyf

    Which Alexa device are you using?

    Also make sure the camera is configured for AAC audio encoding in the camera’s own web config (or disabled).

    This RTSP URL looks correct for Dahua cameras.

    rtsp://IP:PORT/live/cam/realmonitor?channel=1&subtype=1
    

    i’m using the Echo Show 5



  • @andyf

    The Echo Show 5 requires using our Monocle Gateway software in addition to the IP camera and Alexa device on your network.

    Please see:

    Thanks, Robert



  • @Monocle said in Dahua IPC-HFW2100 : i can't make it work:

    @andyf

    The Echo Show 5 requires using our Monocle Gateway software in addition to the IP camera and Alexa device on your network.

    Please see:

    Thanks, Robert

    I’m already using the Monocle Gateway installed with Docker in my Synology DS 718+ , i have other 2 hikvision 2mpx vandalproff outdoor cameras that are working with Echo Show 5 !



  • @andyf
    Can you post a log from the Monocle Gateway where you ask Alexa for this camera stream? Let see how far the gateway is getting and maybe that can help determine what’s going wrong.

    Thanks, Robert



  • @Monocle said in Dahua IPC-HFW2100 : i can't make it work:

    @andyf
    Can you post a log from the Monocle Gateway where you ask Alexa for this camera stream? Let see how far the gateway is getting and maybe that can help determine what’s going wrong.

    Thanks, Robert

    log_garage.png



  • @andyf

    OK, it took me a minute to figure out it is reverse order 🙂

    All looks good in terms of the gateway accepting the connection from Alexa and negotiating the RTSP protocol to SETUP and PLAY the stream. So it would appear that the Echo Show 5 is successfully attaching to the stream, but for some reason does not like the stream and stops. (end of the log is missing, so I did not see the disconnect, but I assume it disconnected and attempted two more times.)

    So what to do … you could try playing with the video codec setting on the camera itself and see if you can find a working combination. For the Echo Show 5, the camera’s stream must be at a resolution of 1080P or lower configured on the camera itself. Or you could try to use this tag in addition to the existing tags : @fake-fmtp. This tag will produce a known working codec config signature in the descriptor and in some cases will get the stream working. In some cases the stream may not play for long, but its worth a shot.

    Thanks, Robert



  • this is approximately half of log of this camera attempt, the full log of this “Attempt” for this camera was very long , if compared with the previous log of the camera that works, it was like 3-4 times longer, probably (as you said) the camera does many attempts …i will post the rest of the log, and try also to “play” with the video codecs like you suggested me!

    Thank You


Log in to reply