Problem with Alexa



  • Hello,
    My camera is C2 Pro (Reolink)
    I used VLC to verify that my feed string is correct = Done !
    Alexa recognise my camera’s name but don’t visualise my picture…

    here an example of camera feed on monocle.com

    [
    {
    “timestamp”: “2019-06-20T09:40:42.411Z”,
    “request”: “InitializeCameraStreams”,
    “response”: [
    {
    “uri”: “rtsp://%USER%:%PWD%@192.168.1.19:554/h264Preview_01_sub”,
    “proxy”: “rtsp://proxy.monoclecam.com:443/3ff5a311-4f73-48e1-a8b8-ac9f1e71a7dc”,
    “idleTimeoutSeconds”: “2”,
    “resolution”: {
    “width”: “640”,
    “height”: “480”
    },
    “authorizationType”: “BASIC”,
    “videoCodec”: “H264”,
    “audioCodec”: “NONE”,
    “protocol”: “RTSP”
    }
    ]
    },
    {
    “timestamp”: “2019-06-20T09:40:36.646Z”,
    “request”: “InitializeCameraStreams”,
    “response”: [
    {
    “uri”: “rtsp://%USER%:%PWD%@192.168.1.19:554/h264Preview_01_sub”,
    “proxy”: “rtsp://proxy.monoclecam.com:443/49696ffd-573c-4ad8-b688-dd545dc6d131”,
    “idleTimeoutSeconds”: “2”,
    “resolution”: {
    “width”: “640”,
    “height”: “480”
    },
    “authorizationType”: “BASIC”,
    “videoCodec”: “H264”,
    “audioCodec”: “NONE”,
    “protocol”: “RTSP”
    }
    ]
    },
    {
    “timestamp”: “2019-06-20T09:40:33.506Z”,
    “request”: “InitializeCameraStreams”,
    “response”: [
    {
    “uri”: “rtsp://%USER%:%PWD%@192.168.1.19:554/h264Preview_01_sub”,
    “proxy”: “rtsp://proxy.monoclecam.com:443/0f995203-dce4-49ee-bfde-0ebd0e3a4b76”,
    “idleTimeoutSeconds”: “2”,
    “resolution”: {
    “width”: “640”,
    “height”: “480”
    },
    “authorizationType”: “BASIC”,
    “videoCodec”: “H264”,
    “audioCodec”: “NONE”,
    “protocol”: “RTSP”
    }
    ]
    },
    {
    “timestamp”: “2019-06-20T09:39:29.367Z”,
    “request”: “InitializeCameraStreams”,
    “response”: [
    {
    “uri”: “rtsp://%USER%:%PWD%@192.168.1.19:554/h264Preview_01_sub”,
    “proxy”: “rtsp://proxy.monoclecam.com:443/46f5b55f-332e-43e5-a9e2-da60a226d359”,
    “idleTimeoutSeconds”: “2”,
    “resolution”: {
    “width”: “640”,
    “height”: “480”
    },
    “authorizationType”: “BASIC”,
    “videoCodec”: “H264”,
    “audioCodec”: “NONE”,
    “protocol”: “RTSP”
    }
    ]
    },

    what is the problem ?
    Thank you !



  • @Cyrillec

    Please see this compatibility note for Reolink cameras:
    https://forum.monoclecam.com/topic/48/reolink-compatibility-readme

    Thanks, Robert



  • Ok so always problem with Reolink & Alexa ?



  • @Cyrillec

    As far as we know, Reolink Argus cameras don’t support RTSP and all other ReoLink cameras require using our Monocle Gateway software to achieve compatibility. Or course Amazon could fix the issue in Alexa or Reolink could fix it in an updated firmware, but at this point we are not aware of any such fixes. So it should be able to work now, but you would have to use the Monocle Gateway locally.

    Thanks, Robert


Log in to reply